aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qemu
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-11-24 13:40:08 -0800
committerKhem Raj <raj.khem@gmail.com>2010-11-24 13:40:08 -0800
commitfe798c3a31ee44591fdcecccfa9832f55caeaf1a (patch)
tree47fbacec29c5622341eb3b4ae0c9d775a79bfcc5 /recipes/qemu
parent76a34ad64457126ea7b3bfeb7d64caa54a84ddd9 (diff)
downloadopenembedded-fe798c3a31ee44591fdcecccfa9832f55caeaf1a.tar.gz
qemu_0.13.0.bb: Fix parallel make build failure
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/qemu')
-rw-r--r--recipes/qemu/qemu-0.13.0/parallel-build.patch16
-rw-r--r--recipes/qemu/qemu_0.13.0.bb3
2 files changed, 18 insertions, 1 deletions
diff --git a/recipes/qemu/qemu-0.13.0/parallel-build.patch b/recipes/qemu/qemu-0.13.0/parallel-build.patch
new file mode 100644
index 0000000000..eb4afcf2c3
--- /dev/null
+++ b/recipes/qemu/qemu-0.13.0/parallel-build.patch
@@ -0,0 +1,16 @@
+This patch is taken from
+https://bugs.gentoo.org/show_bug.cgi?id=343175
+-Khem
+
+--- a/rules.mak 2010-11-03 01:05:54.765852993 +0000
++++ b/rules.mak 2010-11-03 01:06:54.234107851 +0000
+@@ -14,7 +14,7 @@
+ # Flags for dependency generation
+ QEMU_DGFLAGS += -MMD -MP -MT $@ -MF $(*D)/$(*F).d
+
+-%.o: %.c
++%.o: %.c $(GENERATED_HEADERS)
+ $(call quiet-command,$(CC) $(QEMU_CFLAGS) $(QEMU_DGFLAGS) $(CFLAGS) -c -o $@ $<," CC $(TARGET_DIR)$@")
+
+ %.o: %.S
+
diff --git a/recipes/qemu/qemu_0.13.0.bb b/recipes/qemu/qemu_0.13.0.bb
index 8e9539c60f..eec9cdc0b1 100644
--- a/recipes/qemu/qemu_0.13.0.bb
+++ b/recipes/qemu/qemu_0.13.0.bb
@@ -1,12 +1,13 @@
LICENSE = "GPL"
DEPENDS = "zlib ncurses gnutls"
-
+PR = "r1"
SRC_URI = "\
http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \
file://leftover.patch \
file://91-oh-sdl-cursor.patch \
file://fix_baum_c_compilation.patch \
file://fallback.to.safe.mmap_min_addr.patch \
+ file://parallel-build.patch \
"
SRC_URI[md5sum] = "397a0d665da8ba9d3b9583629f3d6421"
SRC_URI[sha256sum] = "1e6f5851b05cea6e377c835f4668408d4124cfb845f9948d922808743c5fd877"