aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sphinx-speech
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sphinx-speech
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sphinx-speech')
-rw-r--r--recipes/sphinx-speech/pocketsphinx/cross-compile.patch11
-rw-r--r--recipes/sphinx-speech/pocketsphinx_0.2.1.bb13
-rw-r--r--recipes/sphinx-speech/pocketsphinx_0.4.1.bb13
-rw-r--r--recipes/sphinx-speech/sphinx-fpu.inc6
-rw-r--r--recipes/sphinx-speech/sphinxbase_0.1.bb14
-rw-r--r--recipes/sphinx-speech/sphinxbase_0.3.bb14
6 files changed, 71 insertions, 0 deletions
diff --git a/recipes/sphinx-speech/pocketsphinx/cross-compile.patch b/recipes/sphinx-speech/pocketsphinx/cross-compile.patch
new file mode 100644
index 0000000000..4392204657
--- /dev/null
+++ b/recipes/sphinx-speech/pocketsphinx/cross-compile.patch
@@ -0,0 +1,11 @@
+--- foo/configure.in.org 2006-08-05 15:42:56.000000000 +0000
++++ foo/configure.in 2006-10-11 22:53:44.000000000 +0000
+@@ -59,7 +59,7 @@
+ dnl FIXME: How do we find the installed headers robustly?
+ dnl
+ AC_CHECK_HEADER(sphinxbase/sphinx_config.h,
+-CPPFLAGS="-I/usr/include/sphinxbase -I/usr/local/include/sphinxbase",[
++CPPFLAGS="$CPPFLAGS",[
+ if test x$sphinxbase = x; then
+ # Look for sphinxbase in the parent directory
+ for sb in ../sphinxbase*; do
diff --git a/recipes/sphinx-speech/pocketsphinx_0.2.1.bb b/recipes/sphinx-speech/pocketsphinx_0.2.1.bb
new file mode 100644
index 0000000000..813146ed86
--- /dev/null
+++ b/recipes/sphinx-speech/pocketsphinx_0.2.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "CMU PocketSphinx - speech recognition engine for handhelds"
+HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
+LICENSE = "BSD"
+DEPENDS = "sphinxbase"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/${PN}-${PV}.tar.bz2 \
+ file://cross-compile.patch;patch=1"
+
+inherit autotools
+
+do_configure () {
+ CPPFLAGS="-I${STAGING_INCDIR}/sphinxbase" oe_runconf
+}
diff --git a/recipes/sphinx-speech/pocketsphinx_0.4.1.bb b/recipes/sphinx-speech/pocketsphinx_0.4.1.bb
new file mode 100644
index 0000000000..813146ed86
--- /dev/null
+++ b/recipes/sphinx-speech/pocketsphinx_0.4.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "CMU PocketSphinx - speech recognition engine for handhelds"
+HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
+LICENSE = "BSD"
+DEPENDS = "sphinxbase"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/${PN}-${PV}.tar.bz2 \
+ file://cross-compile.patch;patch=1"
+
+inherit autotools
+
+do_configure () {
+ CPPFLAGS="-I${STAGING_INCDIR}/sphinxbase" oe_runconf
+}
diff --git a/recipes/sphinx-speech/sphinx-fpu.inc b/recipes/sphinx-speech/sphinx-fpu.inc
new file mode 100644
index 0000000000..73ae2ec16e
--- /dev/null
+++ b/recipes/sphinx-speech/sphinx-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_sphinx_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--enable-fixed"
+ return ""
+
diff --git a/recipes/sphinx-speech/sphinxbase_0.1.bb b/recipes/sphinx-speech/sphinxbase_0.1.bb
new file mode 100644
index 0000000000..2830b9010a
--- /dev/null
+++ b/recipes/sphinx-speech/sphinxbase_0.1.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Base library for CMU Sphinx speech recognition engines"
+HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/sphinxbase-${PV}.tar.bz2"
+
+inherit autotools
+
+require sphinx-fpu.inc
+EXTRA_OECONF += "${@get_sphinx_fpu_setting(bb, d)}"
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/sphinx-speech/sphinxbase_0.3.bb b/recipes/sphinx-speech/sphinxbase_0.3.bb
new file mode 100644
index 0000000000..2830b9010a
--- /dev/null
+++ b/recipes/sphinx-speech/sphinxbase_0.3.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Base library for CMU Sphinx speech recognition engines"
+HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/sphinxbase-${PV}.tar.bz2"
+
+inherit autotools
+
+require sphinx-fpu.inc
+EXTRA_OECONF += "${@get_sphinx_fpu_setting(bb, d)}"
+
+do_stage () {
+ autotools_stage_all
+}