aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2010-12-28 21:55:48 -0600
committerMike Westerhof <mwester@dls.net>2010-12-28 21:55:48 -0600
commit0799fe9dd1ad3effeeec65c5626af2c96099a99e (patch)
tree3bb928450dec1968db52d4e328955190778236c4 /recipes/tasks
parentfacd414805afde48559694da1bc0623bd6727fb7 (diff)
downloadopenembedded-0799fe9dd1ad3effeeec65c5626af2c96099a99e.tar.gz
SlugOS: fix module loading problem and image size problems:
- add explicit dependency so that cross depmod will at image creation - switch to busybox 1.18.0 and add defconfig for SlugOS - remove cpio from image (experiment with busybox version) - remove sysvinit-pidof and dependencies from image - clean up syntax and add qemuarm for compatible machines
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-slugos.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes/tasks/task-slugos.bb b/recipes/tasks/task-slugos.bb
index 297d6f0659..88475cda9b 100644
--- a/recipes/tasks/task-slugos.bb
+++ b/recipes/tasks/task-slugos.bb
@@ -6,9 +6,9 @@
DESCRIPTION = "Task packages for the SlugOS distribution"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r27"
+PR = "r28"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(nslu2|ixp4xx|sheevaplug)"
+COMPATIBLE_MACHINE = "(nslu2|ixp4xx|sheevaplug|qemuarm)"
ALLOW_EMPTY = "1"
#----------------------------------------------------------------------------------
@@ -25,9 +25,9 @@ SLUGOS_MACHINE_RDEPENDS = ""
SLUGOS_MACHINE_RRECOMMENDS = ""
# The full cpio (non-busybox) is required for turnup and sysconfig.
-SLUGOS_STANDARD_RRECOMMENDS += "\
-cpio \
-"
+##SLUGOS_STANDARD_RRECOMMENDS += "\
+##cpio \
+##"
# These lines add support for formatting ext2 and ext3 file systems
# on a hard disk attached to the NSLU2. ext3 is the standard Linux
@@ -126,16 +126,16 @@ DISTRO_EXTRA_RDEPENDS ?= ""
## SlugOS 5.0 - module-init-tools replaced by busybox as well - MJW
## SlugOS 5.2 - module-init-tools reinstated due to busybox bugs - MJW
## SlugOS 5.4 - util-linux-mount reinstated due to busybox bugs - MJW
-
+## SlugOS 5.6 - util-linux-mount dropped once again
+## - remove sysvinit; provided via image.bbclass
RDEPENDS_${PN} += "\
kernel \
base-files base-passwd netbase \
busybox initscripts-slugos slugos-init \
- update-modules sysvinit udev \
+ update-modules udev \
module-init-tools modutils-initscripts \
libgcc \
beep \
- util-linux-mount \
${SLUGOS_STANDARD_RDEPENDS} \
${SLUGOS_MACHINE_RDEPENDS} \
${DISTRO_EXTRA_RDEPENDS}"