aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-15 22:07:11 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-15 22:09:14 -0700
commit295db8cb3f7f2b3d29a86304b60527d0346048aa (patch)
tree1b8ffe453008995e456c2a586e83d29969a30b33 /recipes/tasks
parent3123b4d1cf15d2e835e2e9287fa51aeee4722d55 (diff)
downloadopenembedded-295db8cb3f7f2b3d29a86304b60527d0346048aa.tar.gz
qt4e-demo-image: Switch to using task-qt4e.bb
In task-qt4e.bb put the xmlpatterns bits in RRECOMMENDS for QT 4.6.x Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/tasks')
-rw-r--r--recipes/tasks/task-qt4e.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/tasks/task-qt4e.bb b/recipes/tasks/task-qt4e.bb
new file mode 100644
index 0000000000..057672300c
--- /dev/null
+++ b/recipes/tasks/task-qt4e.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "QT4 Embedded base Image Feed"
+PR = "r0"
+LICENSE = "MIT"
+
+inherit task
+
+PACKAGES += " \
+ ${PN}-base \
+ ${PN}-qwt \
+"
+
+RDEPENDS_${PN}-base = " \
+ qt4-embedded \
+ libqt-embedded3support4 \
+ libqt-embeddedclucene4 \
+ libqt-embeddedcore4 \
+ libqt-embeddeddbus4 \
+ libqt-embeddedgui4 \
+ libqt-embeddedhelp4 \
+ libqt-embeddedmultimedia4 \
+ libqt-embeddednetwork4 \
+ libqt-embeddedscript4 \
+ libqt-embeddedscripttools4 \
+ libqt-embeddedsql4 \
+ libqt-embeddedsvg4 \
+ libqt-embeddedtest4 \
+ libqt-embeddedwebkit4 \
+ libqt-embeddedxml4 \
+ qt4-embedded-fonts-ttf-dejavu \
+ qt4-embedded-fonts-ttf-vera \
+ qt4-embedded-plugin-iconengine-svgicon \
+ qt4-embedded-plugin-imageformat-gif \
+ qt4-embedded-plugin-imageformat-ico \
+ qt4-embedded-plugin-imageformat-jpeg \
+ qt4-embedded-plugin-imageformat-mng \
+ qt4-embedded-plugin-imageformat-svg \
+ qt4-embedded-plugin-imageformat-tiff \
+ qt4-embedded-plugin-mousedriver-tslib \
+ qt4-embedded-plugin-phonon-backend-gstreamer \
+ qt4-embedded-plugin-script-dbus \
+ qt4-embedded-plugin-sqldriver-sqlite2 \
+ qt4-embedded-plugin-sqldriver-sqlite \
+"
+
+RRECOMMENDS_${PN}-base = " \
+ libqt-embeddedxmlpatterns4 \
+"
+
+RDEPENDS_${PN}-qwt = "\
+ qwt-e \
+"