aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2010-12-21 13:21:57 -0600
committerKoen Kooi <koen@openembedded.org>2011-01-06 16:42:29 +0100
commit77cc42b7c2b69fbb33411af2f8eb7bc67361941f (patch)
tree9862b5ae8be35f4eb543ffd774e30b033b79e48b /recipes/ti
parent15870da5ef893e1e1dafacd34ce7fd9f3525af4b (diff)
downloadopenembedded-77cc42b7c2b69fbb33411af2f8eb7bc67361941f.tar.gz
ti-ocf-crypto-module: add crypto module for hw accel
* Added the module for the OCF subsystem that allows access to the crypto accelerator hardware on the am37x device. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-ocf-crypto-module_1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/ti/ti-ocf-crypto-module_1.0.bb b/recipes/ti/ti-ocf-crypto-module_1.0.bb
new file mode 100644
index 0000000000..3f8f248d2e
--- /dev/null
+++ b/recipes/ti/ti-ocf-crypto-module_1.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Builds Crypto module used by OCF-Linux driver in OpenSSL example applications"
+HOMEPAGE = "https://gforge.ti.com/gf/project/arm_crypto/"
+LICENSE = "BSD GPLv2"
+
+COMPATIBLE_MACHINE = "omap3"
+
+SRC_URI = "svn://gforge.ti.com/svn/arm_crypto/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+#gforge source revision
+SRCREV = "11"
+
+PACKAGE_STRIP = "no"
+
+S = "${WORKDIR}/trunk"
+
+inherit module
+
+PR = "${MACHINE_KERNEL_PR}+svnr${SRCPV}"
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
+ install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
+}
+
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/crypto/ocf/ocf_omap3_cryptok.ko"