aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
authorEyal Reizer <eyalreizer@googlemail.com>2011-06-06 13:57:05 +0000
committerDenys Dmytriyenko <denys@ti.com>2011-06-08 16:44:11 -0400
commit8b4f53425b63a5ce8c9cbd2c4036ef0b06a37247 (patch)
tree571a71fc6f9c1eb747223fc8825ad247b36c1384 /recipes/ti
parentc55f9f3c92db5b7dd6b67dfddf37dfdf4980cc53 (diff)
downloadopenembedded-8b4f53425b63a5ce8c9cbd2c4036ef0b06a37247.tar.gz
ti-wifi-utils: install calibrator ini files to rootfs
In order to perform wifi calibration the calibrator needs to be provided with a reference NVS file that matches the wifi chip and the radio module that is being used. This patch install these ini files to the root file system along with the calibrator itself. Signed-off-by: Eyal Reizer <eyalr@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/ti-wifi-utils_git.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes/ti/ti-wifi-utils_git.bb b/recipes/ti/ti-wifi-utils_git.bb
index 567fe29c06..96718debdf 100644
--- a/recipes/ti/ti-wifi-utils_git.bb
+++ b/recipes/ti/ti-wifi-utils_git.bb
@@ -3,7 +3,7 @@ LICENCE = "TI-BSD"
DEPENDS = "libnl"
-PR ="r2"
+PR ="r3"
PV ="0.0"
PR_append = "+gitr${SRCPV}"
@@ -17,5 +17,15 @@ CFLAGS += " -DCONFIG_LIBNL20"
do_install() {
install -d ${D}${bindir}
+ install -d ${D}${datadir}/ti/wifi-utils/ini_files/127x
+ install -d ${D}${datadir}/ti/wifi-utils/ini_files/128x
+
install -m 0755 calibrator ${D}${bindir}/
+ install -m 0755 ${S}/ini_files/127x/* ${D}${datadir}/ti/wifi-utils/ini_files/127x
+ install -m 0755 ${S}/ini_files/128x/* ${D}${datadir}/ti/wifi-utils/ini_files/128x
}
+
+FILES_${PN} += " \
+ ${datadir}/ti/wifi-utils/ini_files/127x \
+ ${datadir}/ti/wifi-utils/ini_files/128x \
+"