aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tmake
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tmake
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tmake')
-rw-r--r--recipes/tmake/tmake_1.11.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/tmake/tmake_1.11.bb b/recipes/tmake/tmake_1.11.bb
new file mode 100644
index 0000000000..9d1ecd1a2a
--- /dev/null
+++ b/recipes/tmake/tmake_1.11.bb
@@ -0,0 +1,28 @@
+SRC_URI = "ftp://ftp.trolltech.com/pub/freebies/tmake/tmake-${PV}.tar.gz"
+DESCRIPTION = "tmake is an easy-to-use tool for creating and maintaining makefiles across many platforms and compilers."
+LICENSE = "Unknown"
+DEPENDS = ""
+SECTION = "devel"
+PRIORITY = "optional"
+
+S = "${WORKDIR}/tmake-${PV}"
+
+# Ick. This .bb file should really have a -native version doing this, even if it is a perl script... RP
+do_stage() {
+ install -m 0755 bin/tmake bin/progen ${STAGING_BINDIR_NATIVE}/
+
+ install -d ${STAGING_DATADIR}/tmake
+ cp -R lib/* ${STAGING_DATADIR}/tmake/
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 bin/tmake bin/progen ${D}${bindir}/
+
+ install -d ${D}${datadir}/tmake
+ cp -R lib/* ${D}${datadir}/tmake/
+}
+
+PACKAGES = "${PN}-dbg tmake"
+FILES = ""
+FILES_tmake="${bindir} ${datadir}/tmake"