aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tor
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tor
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tor')
-rwxr-xr-xrecipes/tor/files/tor.init44
-rw-r--r--recipes/tor/tor-0.1.1.26/compat.patch14
-rw-r--r--recipes/tor/tor-0.1.1.26/configure.patch126
-rw-r--r--recipes/tor/tor-0.1.1.26/make.patch11
-rw-r--r--recipes/tor/tor-0.1.1.26/openssl.patch71
-rw-r--r--recipes/tor/tor_0.1.1.26.bb23
6 files changed, 289 insertions, 0 deletions
diff --git a/recipes/tor/files/tor.init b/recipes/tor/files/tor.init
new file mode 100755
index 0000000000..e421347440
--- /dev/null
+++ b/recipes/tor/files/tor.init
@@ -0,0 +1,44 @@
+
+#! /bin/sh
+#
+# This is an init script for Tor on Openzaurus
+#
+
+
+test -f /usr/bin/tor || exit 0
+test -f /etc/tor/tor-tsocks.conf || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting tor daemon"
+ start-stop-daemon --start --quiet --exec /usr/bin/tor &
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping tor daemon"
+ start-stop-daemon --stop --quiet --exec /usr/bin/tor &
+ echo "."
+ ;;
+ restart)
+ echo -n "Stopping tor daemon"
+ start-stop-daemon --stop --quiet --exec /usr/bin/tor &
+ sleep 1
+ echo -n "Starting tor daemon"
+ start-stop-daemon --start --quiet --exec /usr/bin/tor &
+ echo "."
+ ;;
+ start_socats)
+ echo "Starting socats"
+ # EXAMPLE
+ socat TCP4-LISTEN:6667,fork SOCKS4A:localhost:irc.freenode.net:6667,socksport=9050 &
+ ;;
+ stop_socats)
+ echo "Stopping all socat processes!"
+ killall socat
+ ;;
+ *)
+ echo "Usage: /etc/init.d/tor {start|stop|restart|start_socats|stop_socats}"
+ exit 1
+esac
+
+exit 0
diff --git a/recipes/tor/tor-0.1.1.26/compat.patch b/recipes/tor/tor-0.1.1.26/compat.patch
new file mode 100644
index 0000000000..6c54032667
--- /dev/null
+++ b/recipes/tor/tor-0.1.1.26/compat.patch
@@ -0,0 +1,14 @@
+diff -Naur tor-0.1.1.23/src/common/compat.h tor-0.1.1.23_patched/src/common/compat.h
+--- tor-0.1.1.23/src/common/compat.h 2006-07-25 05:52:47.000000000 +0200
++++ tor-0.1.1.23_patched/src/common/compat.h 2006-09-04 22:26:42.000000000 +0200
+@@ -31,10 +31,6 @@
+ #endif
+ #include <stdarg.h>
+
+-#ifndef NULL_REP_IS_ZERO_BYTES
+-#error "It seems your platform does not represent NULL as zero. We can't cope."
+-#endif
+-
+ /* ===== Compiler compatibility */
+
+ /* GCC can check printf types on arbitrary functions. */
diff --git a/recipes/tor/tor-0.1.1.26/configure.patch b/recipes/tor/tor-0.1.1.26/configure.patch
new file mode 100644
index 0000000000..dcd214feb2
--- /dev/null
+++ b/recipes/tor/tor-0.1.1.26/configure.patch
@@ -0,0 +1,126 @@
+diff -Naur tor-0.1.1.23/configure.in tor-0.1.1.23_patched/configure.in
+--- tor-0.1.1.23/configure.in 2006-07-30 06:40:28.000000000 +0200
++++ tor-0.1.1.23_patched/configure.in 2006-09-04 22:18:15.000000000 +0200
+@@ -169,38 +169,6 @@
+ fi
+ fi
+
+-AC_CACHE_CHECK([whether we need extra options to link libevent],
+- ac_cv_libevent_linker_option, [
+- saved_LDFLAGS="$LDFLAGS"
+- le_runs=no
+- linked_with=nothing
+- for le_extra in "" "-Wl,-R$le_libdir" "-R$le_libdir" ; do
+- LDFLAGS="$le_extra $saved_LDFLAGS"
+- AC_TRY_RUN([void *event_init(void);
+- int main(int c, char **v) {
+- event_init(); return 0;
+- }],
+- libevent_runs=yes, libevent_runs=no)
+- if test $libevent_runs = yes ; then
+- if test -z "$le_extra" ; then
+- ac_cv_libevent_linker_option='(none)'
+- else
+- ac_cv_libevent_linker_option=$le_extra
+- fi
+- le_runs=yes
+- break
+- fi
+- done
+- if test $le_runs = no ; then
+- AC_MSG_ERROR([Found linkable libevent in $ac_cv_libevent_dir, but it doesn't run, even with -R. Maybe specify another using --with-libevent-dir?])
+- fi
+- LDFLAGS="$saved_LDFLAGS"
+-])
+-
+-if test $ac_cv_libevent_linker_option != '(none)' ; then
+- LDFLAGS="$ac_cv_libevent_linker_option $LDFLAGS"
+-fi
+-
+ dnl ------------------------------------------------------
+ dnl Where do you live, openssl? And how do we call you?
+
+@@ -266,66 +234,6 @@
+ fi
+ fi
+
+-AC_CACHE_CHECK([whether we need extra options to link OpenSSL],
+- ac_cv_openssl_linker_option, [
+- saved_LDFLAGS="$LDFLAGS"
+- ssl_runs=no
+- linked_with=nothing
+- for ssl_extra in "" "-Wl,-R$ssl_libdir" "-R$ssl_libdir" ; do
+- LDFLAGS="$ssl_extra $saved_LDFLAGS"
+- AC_TRY_RUN([
+-#include <string.h>
+-#include <openssl/rand.h>
+-int main(void)
+-{
+- char a[2048];
+- memset(a, 0, sizeof(a));
+- RAND_add(a, sizeof(a), sizeof(a));
+- return(RAND_status() <= 0);
+-}
+- ],
+- openssl_runs=yes, openssl_runs=no)
+- if test $openssl_runs = yes ; then
+- if test "$linked_with" = nothing; then
+- linked_with="$ssl_extra"
+- fi
+- AC_TRY_RUN([
+-#include <openssl/opensslv.h>
+-#include <openssl/crypto.h>
+-int main(void) {
+-return (OPENSSL_VERSION_NUMBER == SSLeay()) == 0;
+-}],
+- right_version=yes, right_version=no)
+- if test "$right_version" = yes; then
+- if test -z "$ssl_extra" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$ssl_extra
+- fi
+- ssl_runs=yes
+- break
+- fi
+- fi
+- done
+- if test $ssl_runs = no ; then
+- if test "$linked_with" = 'nothing' ; then
+- AC_MSG_ERROR([Found linkable OpenSSL in $ac_cv_openssl_dir, but it doesn't run, even with -R. Maybe specify another using --with-ssl-dir?])
+- else
+- if test -z "$linked_with" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$linked_with
+- fi
+- AC_MSG_WARN([I managed to make OpenSSL link and run, but I couldn't make it link against the same version I found header files for.])
+- fi
+- fi
+- LDFLAGS="$saved_LDFLAGS"
+-])
+-
+-if test "$ac_cv_openssl_linker_option" != '(none)' ; then
+- LDFLAGS="$ac_cv_openssl_linker_option $LDFLAGS"
+-fi
+-
+ dnl Make sure to enable support for large off_t if avalable.
+
+ AC_SYS_LARGEFILE
+@@ -377,16 +285,6 @@
+ AC_CHECK_SIZEOF(__int64)
+ AC_CHECK_SIZEOF(void *)
+ AC_CHECK_SIZEOF(time_t)
+-AC_CACHE_CHECK([whether time_t is signed], tor_cv_time_t_signed, [
+-AC_TRY_RUN([
+-int main(int c, char**v) { if (((time_t)-1)<0) return 1; else return 0; }],
+- tor_cv_time_t_signed=no, tor_cv_time_t_signed=yes)
+-])
+-
+-if test $tor_cv_time_t_signed = yes; then
+- AC_DEFINE([TIME_T_IS_SIGNED], 1,
+- [Define to 1 iff time_t is signed])
+-fi
+
+ AC_CHECK_SIZEOF(socklen_t, , [AC_INCLUDES_DEFAULT()
+ #ifdef HAVE_SYS_SOCKET_H
diff --git a/recipes/tor/tor-0.1.1.26/make.patch b/recipes/tor/tor-0.1.1.26/make.patch
new file mode 100644
index 0000000000..8b8851b22b
--- /dev/null
+++ b/recipes/tor/tor-0.1.1.26/make.patch
@@ -0,0 +1,11 @@
+diff -Naur tor-0.1.1.23/Makefile.in tor-0.1.1.23_patched/Makefile.in
+--- tor-0.1.1.23/Makefile.in 2006-07-30 06:42:20.000000000 +0200
++++ tor-0.1.1.23_patched/Makefile.in 2006-09-04 20:13:51.000000000 +0200
+@@ -65,7 +65,6 @@
+ host_alias = @host_alias@
+ host_triplet = @host@
+ BINDIR = @BINDIR@
+-CC = @CC@
+ CONFDIR = @CONFDIR@
+ HAVE_LIB = @HAVE_LIB@
+ LIB = @LIB@
diff --git a/recipes/tor/tor-0.1.1.26/openssl.patch b/recipes/tor/tor-0.1.1.26/openssl.patch
new file mode 100644
index 0000000000..e413486273
--- /dev/null
+++ b/recipes/tor/tor-0.1.1.26/openssl.patch
@@ -0,0 +1,71 @@
+diff -Naur tor-0.1.1.23/configure.in tor-0.1.1.23_patched/configure.in
+--- tor-0.1.1.23/configure.in 2006-09-04 20:42:21.000000000 +0200
++++ tor-0.1.1.23_patched/configure.in 2006-09-04 20:45:09.000000000 +0200
+
+@@ -234,66 +234,6 @@
+ fi
+ fi
+
+-AC_CACHE_CHECK([whether we need extra options to link OpenSSL],
+- ac_cv_openssl_linker_option, [
+- saved_LDFLAGS="$LDFLAGS"
+- ssl_runs=no
+- linked_with=nothing
+- for ssl_extra in "" "-Wl,-R$ssl_libdir" "-R$ssl_libdir" ; do
+- LDFLAGS="$ssl_extra $saved_LDFLAGS"
+- AC_TRY_RUN([
+-#include <string.h>
+-#include <openssl/rand.h>
+-int main(void)
+-{
+- char a[2048];
+- memset(a, 0, sizeof(a));
+- RAND_add(a, sizeof(a), sizeof(a));
+- return(RAND_status() <= 0);
+-}
+- ],
+- openssl_runs=yes, openssl_runs=no)
+- if test $openssl_runs = yes ; then
+- if test "$linked_with" = nothing; then
+- linked_with="$ssl_extra"
+- fi
+- AC_TRY_RUN([
+-#include <openssl/opensslv.h>
+-#include <openssl/crypto.h>
+-int main(void) {
+-return (OPENSSL_VERSION_NUMBER == SSLeay()) == 0;
+-}],
+- right_version=yes, right_version=no)
+- if test "$right_version" = yes; then
+- if test -z "$ssl_extra" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$ssl_extra
+- fi
+- ssl_runs=yes
+- break
+- fi
+- fi
+- done
+- if test $ssl_runs = no ; then
+- if test "$linked_with" = 'nothing' ; then
+- AC_MSG_ERROR([Found linkable OpenSSL in $ac_cv_openssl_dir, but it doesn't run, even with -R. Maybe specify another using --with-ssl-dir?])
+- else
+- if test -z "$linked_with" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$linked_with
+- fi
+- AC_MSG_WARN([I managed to make OpenSSL link and run, but I couldn't make it link against the same version I found header files for.])
+- fi
+- fi
+- LDFLAGS="$saved_LDFLAGS"
+-])
+-
+-if test "$ac_cv_openssl_linker_option" != '(none)' ; then
+- LDFLAGS="$ac_cv_openssl_linker_option $LDFLAGS"
+-fi
+-
+ dnl Make sure to enable support for large off_t if avalable.
+
+ AC_SYS_LARGEFILE
diff --git a/recipes/tor/tor_0.1.1.26.bb b/recipes/tor/tor_0.1.1.26.bb
new file mode 100644
index 0000000000..51ff1001dd
--- /dev/null
+++ b/recipes/tor/tor_0.1.1.26.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Tor is a network of virtual tunnels that allows people and groups \
+ to improve their privacy and security on the Internet."
+HOMEPAGE = "http://tor.eff.org"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "BSD"
+DEPENDS = "libevent openssl zlib"
+
+SRC_URI = "http://tor.eff.org/dist/${P}.tar.gz \
+ file://configure.patch;patch=1;pnum=1 \
+ file://make.patch;patch=1;pnum=1 \
+ file://compat.patch;patch=1;pnum=1 \
+ file://tor.init"
+
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "tor"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install ${WORKDIR}/tor.init ${D}${sysconfdir}/init.d/tor
+}