aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-mkimage-1.3.2
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-20 11:08:43 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-20 12:01:06 +0200
commit039497007619829f936a63643b331d2b1d7429ad (patch)
tree83787b31c11768cb98467cc009c429767df22ab2 /recipes/u-boot/u-boot-mkimage-1.3.2
parent236f580a535236169a813a792f7702c38b38a5b5 (diff)
downloadopenembedded-039497007619829f936a63643b331d2b1d7429ad.tar.gz
u-boot-mkimage: convert to new style staging and bbclassextend
Diffstat (limited to 'recipes/u-boot/u-boot-mkimage-1.3.2')
-rw-r--r--recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch b/recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch
new file mode 100644
index 0000000000..69cb75891d
--- /dev/null
+++ b/recipes/u-boot/u-boot-mkimage-1.3.2/fix-arm920t-eabi.patch
@@ -0,0 +1,22 @@
+---
+ cpu/arm920t/config.mk | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- u-boot-1.3.2.orig/cpu/arm920t/config.mk
++++ u-boot-1.3.2/cpu/arm920t/config.mk
+@@ -22,13 +22,13 @@
+ #
+
+ PLATFORM_RELFLAGS += -fno-strict-aliasing -fno-common -ffixed-r8 \
+ -msoft-float
+
+-PLATFORM_CPPFLAGS += -march=armv4
++#PLATFORM_CPPFLAGS += -march=armv4
+ # =========================================================================
+ #
+ # Supply options according to compiler version
+ #
+ # =========================================================================
+-PLATFORM_CPPFLAGS +=$(call cc-option,-mapcs-32,-mabi=apcs-gnu)
++PLATFORM_CPPFLAGS +=$(call cc-option)
+ PLATFORM_RELFLAGS +=$(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))