aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot_1.3.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/u-boot/u-boot_1.3.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u-boot/u-boot_1.3.2.bb')
-rw-r--r--recipes/u-boot/u-boot_1.3.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot_1.3.2.bb b/recipes/u-boot/u-boot_1.3.2.bb
new file mode 100644
index 0000000000..59ebaecabd
--- /dev/null
+++ b/recipes/u-boot/u-boot_1.3.2.bb
@@ -0,0 +1,48 @@
+require u-boot.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r11"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+SRC_URI_append_mpc8313e-rdb = "\
+ file://mpc8313e-rdb-autoboot.patch;patch=1 \
+ file://mpc8313e-rdb-nand.patch;patch=1 \
+ file://mpc8313e-rdb-mtdparts.patch;patch=1 \
+ file://mpc8313e-rdb-eeprom.patch;patch=1 \
+ file://mpc8313e-rdb-lm75.patch;patch=1 \
+ file://u-boot-fsl-1.3.0-mpc8313erdb-vsc7385-support.patch;patch=1 \
+ file://u-boot-fsl-1.3.0-mpc8313erdb-fix-vitesse-7385-firmware.patch;patch=1 \
+ file://u-boot-fsl-1.3.0-mpc8313erdb-performance-tuning-for-TSEC.patch;patch=1 \
+ "
+
+SRC_URI_append_boc01 = "\
+ file://mpc8313e-rdb-autoboot.patch;patch=1 \
+ file://mpc8313e-rdb-nand.patch;patch=1 \
+ file://mpc8313e-rdb-mtdparts.patch;patch=1 \
+ file://mpc8313e-rdb-eeprom.patch;patch=1 \
+ file://001-090205-SPI.patch;patch=1 \
+ file://002-081212-GPIO.patch;patch=1 \
+ file://003-081205-DTT_LM73.patch;patch=1 \
+ file://004-081205-WATCHDOG.patch;patch=1 \
+ file://006-081211-EEPROM_M24C32.patch;patch=1 \
+ file://007-090217-CAPSENSE.patch;patch=1 \
+ file://008-090107-TSEC.patch;patch=1 \
+ file://009-081212-EXIO.patch;patch=1 \
+ file://010-081212-LCD.patch;patch=1 \
+ file://011-081211-CMD_TEST.patch;patch=1 \
+ file://012-081209-BUG_SETENV.patch;patch=1 \
+ file://013-090206-FIX_OOB_8BITS_LARGEPAGE_NAND.patch;patch=1 \
+ file://014-081211-BOOT_RESCUE.patch;patch=1 \
+ file://015-090205-EMC.patch;patch=1 \
+ file://016-090209-PM.patch;patch=1 \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_deploy_append_mpc8313e-rdb () {
+ install ${S}/examples/vsc7385_load/vsc7385_load.bin ${DEPLOY_DIR_IMAGE}/vsc7385_load.bin
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/vsc7385_load.bin
+}
+