aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uclibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-18 14:02:33 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-18 14:05:40 -0800
commit2a31f77a175b58d9ab52f8af40029a5f0fae5774 (patch)
tree5c3edc9a87c6b05b7d672a242594242f0f12067d /recipes/uclibc
parente6c26bacb703e0aa4a76b2befbe6244aee6ccf4e (diff)
downloadopenembedded-2a31f77a175b58d9ab52f8af40029a5f0fae5774.tar.gz
uclibc_git.bb: Fix the build on mips64/nptl
* It does not yet boot though but one step at a time Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/uclibc')
-rw-r--r--recipes/uclibc/uclibc-git/mips64-no-waitpid.patch30
-rw-r--r--recipes/uclibc/uclibc_git.bb5
2 files changed, 33 insertions, 2 deletions
diff --git a/recipes/uclibc/uclibc-git/mips64-no-waitpid.patch b/recipes/uclibc/uclibc-git/mips64-no-waitpid.patch
new file mode 100644
index 0000000000..880bb7a46f
--- /dev/null
+++ b/recipes/uclibc/uclibc-git/mips64-no-waitpid.patch
@@ -0,0 +1,30 @@
+Index: git/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch
+===================================================================
+--- git.orig/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch 2011-01-16 21:23:04.612324001 -0800
++++ git/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch 2011-01-16 21:27:57.342324000 -0800
+@@ -10,7 +10,9 @@
+
+ libc_linux_arch_CSRC = fork.c
+ libc_linux_arch_SSRC = clone.S vfork.S
+-
++ifneq ($(CONFIG_MIPS_O32_ABI),y)
++libc_linux_arch_SSRC-OMIT = waitpid.S
++endif
+ ASFLAGS += -DUSE___THREAD
+
+ CFLAGS-OMIT-fork.c = -DNOT_IN_libc -DIS_IN_libpthread
+Index: git/libc/sysdeps/linux/common/Makefile.in
+===================================================================
+--- git.orig/libc/sysdeps/linux/common/Makefile.in 2011-01-16 21:33:51.302324000 -0800
++++ git/libc/sysdeps/linux/common/Makefile.in 2011-01-16 21:41:01.812324000 -0800
+@@ -44,6 +44,10 @@
+ CSRC := $(filter-out vfork.c, $(CSRC))
+ else ifeq ($(TARGET_ARCH),x86_64)
+ CSRC := $(filter-out vfork.c, $(CSRC))
++else ifeq ($(TARGET_ARCH),mips)
++ifeq ($(CONFIG_MIPS_O32_ABI),y)
++CSRC := $(filter-out waitpid.c, $(CSRC))
++endif
+ else
+ CSRC := $(filter-out waitpid.c, $(CSRC))
+ endif
diff --git a/recipes/uclibc/uclibc_git.bb b/recipes/uclibc/uclibc_git.bb
index e206c4fd59..75047bdf69 100644
--- a/recipes/uclibc/uclibc_git.bb
+++ b/recipes/uclibc/uclibc_git.bb
@@ -7,14 +7,14 @@
# on whether the base patches apply to the selected (SRCDATE) svn release.
#
UCLIBC_BASE ?= "0.9.32"
-SRCREV="8fdc17c2ba1322712604d88dca48157068e6aadb"
+SRCREV="387b2e49cbb6aedcc6136fb18fb232dada563cf6"
PR_append = "+gitr${SRCPV}"
DEFAULT_PREFERENCE = "-1"
#DEFAULT_PREFERENCE is 0 (empty), releases have a preference of 1 so take
# precedence.
require uclibc.inc
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
#recent versions uclibc require real kernel headers
@@ -44,5 +44,6 @@ SRC_URI = "git://uclibc.org/uClibc.git;branch=master;protocol=git \
file://0004-Add-protected-symbols-support-for-all-architectures.patch \
file://0005-ldso-get-rid-of-_dl_lookup_hash.patch \
file://pro-sym-mips-fix.patch \
+ file://mips64-no-waitpid.patch \
"
S = "${WORKDIR}/git"