aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uclibc
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/uclibc
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/uclibc')
-rw-r--r--recipes/uclibc/uclibc_0.9.28.bb68
-rw-r--r--recipes/uclibc/uclibc_0.9.29.bb32
-rw-r--r--recipes/uclibc/uclibc_0.9.30.1.bb20
-rw-r--r--recipes/uclibc/uclibc_0.9.30.2.bb10
-rw-r--r--recipes/uclibc/uclibc_0.9.30.3.bb2
-rw-r--r--recipes/uclibc/uclibc_0.9.30.bb14
-rw-r--r--recipes/uclibc/uclibc_git.bb6
7 files changed, 76 insertions, 76 deletions
diff --git a/recipes/uclibc/uclibc_0.9.28.bb b/recipes/uclibc/uclibc_0.9.28.bb
index 5e8da03e6b..a43d5ed462 100644
--- a/recipes/uclibc/uclibc_0.9.28.bb
+++ b/recipes/uclibc/uclibc_0.9.28.bb
@@ -16,22 +16,22 @@ S = "${WORKDIR}/uClibc-${PV}"
# functioning correct now so the patch is not included. It may
# be necessary to add this for architectures which do not initially
# have a 'good' set of kernel header files in the cross directory.
-#SRC_URI += "file://nokernelheadercheck.patch;apply=yes"
+#SRC_URI += "file://nokernelheadercheck.patch"
#
# Thumb support
#
# Thumb interworking support
THUMBSTUFF = " \
- file://thumb-defined-arm-or-thumb.patch;apply=yes \
- file://thumb-mov-pc-bx.patch;apply=yes \
- file://thumb-swi-r7.patch;apply=yes \
- file://thumb-sysnum-h.patch;apply=yes \
- file://thumb-asm-swi.patch;apply=yes \
- file://thumb-call-via-rx.patch;apply=yes \
- file://dl-startup.h.patch;apply=yes \
- file://dl-string.h.patch;apply=yes \
- file://dl-sysdep.h.patch;apply=yes \
- file://uclibc-libgcc-eh.patch;apply=yes \
+ file://thumb-defined-arm-or-thumb.patch \
+ file://thumb-mov-pc-bx.patch \
+ file://thumb-swi-r7.patch \
+ file://thumb-sysnum-h.patch \
+ file://thumb-asm-swi.patch \
+ file://thumb-call-via-rx.patch \
+ file://dl-startup.h.patch \
+ file://dl-string.h.patch \
+ file://dl-sysdep.h.patch \
+ file://uclibc-libgcc-eh.patch \
"
SRC_URI_append_arm = " ${THUMBSTUFF} "
@@ -40,37 +40,37 @@ SRC_URI_append_arm = " ${THUMBSTUFF} "
# This is a core change and is controversial, maybe even wrong
# on some architectures
THUMB_INTERWORK_RESOLVE_PATCH = ""
-THUMB_INTERWORK_RESOLVE_PATCH_thumb-interwork = " file://thumb-resolve.patch;apply=yes"
+THUMB_INTERWORK_RESOLVE_PATCH_thumb-interwork = " file://thumb-resolve.patch"
SRC_URI += " ${THUMB_INTERWORK_RESOLVE_PATCH}"
DEFAULT_PREFERENCE_avr32 = "6000"
SRC_URI_append_avr32 = " \
- file://uclibc-makefile.patch;apply=yes \
- file://remove-bogus-version-hack-and-just-use-asm-generic-if-it-exists.patch;apply=yes \
- file://let-optimized-stringops-override-default-ones.patch;apply=yes \
- file://fix-getrusage-argument-type.patch;apply=yes \
- file://fix-__libc_fcntl64-varargs-prototype.patch;apply=yes \
- file://fix-broken-__libc_open-declaration.patch;apply=yes \
- file://avr32-arch-2.patch;apply=yes \
- file://avr32-linkrelax-option.patch;apply=yes \
- file://avr32-string-ops.patch;apply=yes \
- file://no-create_module-on-avr32.patch;apply=yes \
- file://ldso-always-inline-_dl_memcpy.patch;apply=yes \
- file://ldso-define-MAP_FAILED.patch;apply=yes \
- file://ldso-always-inline-syscalls.patch;apply=yes \
- file://ldso-avr32-2.patch;apply=yes \
- file://ldso-avr32-needs-CONSTANT_STRING_GOT_FIXUP.patch;apply=yes \
- file://ldso-avr32-startup-hack.patch;apply=yes \
- file://ldd-avr32-support.patch;apply=yes \
- file://libpthread-avr32.patch;apply=yes \
- file://sync-fcntl-h-with-linux-kernel.patch;apply=yes \
+ file://uclibc-makefile.patch \
+ file://remove-bogus-version-hack-and-just-use-asm-generic-if-it-exists.patch \
+ file://let-optimized-stringops-override-default-ones.patch \
+ file://fix-getrusage-argument-type.patch \
+ file://fix-__libc_fcntl64-varargs-prototype.patch \
+ file://fix-broken-__libc_open-declaration.patch \
+ file://avr32-arch-2.patch \
+ file://avr32-linkrelax-option.patch \
+ file://avr32-string-ops.patch \
+ file://no-create_module-on-avr32.patch \
+ file://ldso-always-inline-_dl_memcpy.patch \
+ file://ldso-define-MAP_FAILED.patch \
+ file://ldso-always-inline-syscalls.patch \
+ file://ldso-avr32-2.patch \
+ file://ldso-avr32-needs-CONSTANT_STRING_GOT_FIXUP.patch \
+ file://ldso-avr32-startup-hack.patch \
+ file://ldd-avr32-support.patch \
+ file://libpthread-avr32.patch \
+ file://sync-fcntl-h-with-linux-kernel.patch \
"
-#file://uClibc-0.9.28-avr32-20060621.patch;apply=yes \
-#file://uClibc-0.9.28-avr32-20061019.patch;apply=yes \
-#file://uclibc-avr32-no-msoft-float.patch;apply=yes \
+#file://uClibc-0.9.28-avr32-20060621.patch \
+#file://uClibc-0.9.28-avr32-20061019.patch \
+#file://uclibc-avr32-no-msoft-float.patch \
SRC_URI[uClibc-0.9.28.md5sum] = "1ada58d919a82561061e4741fb6abd29"
SRC_URI[uClibc-0.9.28.sha256sum] = "c8bc5383eafaa299e9874ae50acc6549f8b54bc29ed64a9a3387b3e4cd7f4bcb"
diff --git a/recipes/uclibc/uclibc_0.9.29.bb b/recipes/uclibc/uclibc_0.9.29.bb
index 01f848a4ff..b83cd2efe4 100644
--- a/recipes/uclibc/uclibc_0.9.29.bb
+++ b/recipes/uclibc/uclibc_0.9.29.bb
@@ -14,22 +14,22 @@ PR = "${INC_PR}.0"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
SRC_URI += "file://uClibc.machine file://uClibc.distro \
- file://errno_values.h.patch;apply=yes \
- file://termios.h.patch;apply=yes \
- file://unistd_arm.patch;apply=yes \
- file://build_wcs_upper_buffer.patch;apply=yes \
- file://uClibc-0.9.29-001-fix-mmap.patch;apply=yes \
- file://uClibc-0.9.29-002-atmel.1.patch;apply=yes \
- file://uClibc-0.9.29-avr32-fix-sa_onstack.patch;apply=yes \
- file://uClibc-0.9.29-conditional-sched_affinity.patch;apply=yes \
- file://uClibc-0.9.29-fix-gethostent_r-failure-retval.patch;apply=yes \
- file://uClibc-0.9.29-fix-internal_function-definition.patch;apply=yes \
- file://uClibc-0.9.29-rm-whitespace.patch;apply=yes \
- file://uClibc-0.9.29-avr32-bzero.patch;apply=yes \
- file://uClibc-0.9.29-nonposix_bashisms.patch;apply=yes \
- file://arm_fix_alignment.patch;apply=yes \
- file://uclibc-arm-ftruncate64.patch;apply=yes \
- file://uclibc-use-fgnu89-inline.patch;apply=yes \
+ file://errno_values.h.patch \
+ file://termios.h.patch \
+ file://unistd_arm.patch \
+ file://build_wcs_upper_buffer.patch \
+ file://uClibc-0.9.29-001-fix-mmap.patch \
+ file://uClibc-0.9.29-002-atmel.1.patch \
+ file://uClibc-0.9.29-avr32-fix-sa_onstack.patch \
+ file://uClibc-0.9.29-conditional-sched_affinity.patch \
+ file://uClibc-0.9.29-fix-gethostent_r-failure-retval.patch \
+ file://uClibc-0.9.29-fix-internal_function-definition.patch \
+ file://uClibc-0.9.29-rm-whitespace.patch \
+ file://uClibc-0.9.29-avr32-bzero.patch \
+ file://uClibc-0.9.29-nonposix_bashisms.patch \
+ file://arm_fix_alignment.patch \
+ file://uclibc-arm-ftruncate64.patch \
+ file://uclibc-use-fgnu89-inline.patch \
"
#recent versions uclibc require real kernel headers
diff --git a/recipes/uclibc/uclibc_0.9.30.1.bb b/recipes/uclibc/uclibc_0.9.30.1.bb
index 18126cb8b5..ea6924977a 100644
--- a/recipes/uclibc/uclibc_0.9.30.1.bb
+++ b/recipes/uclibc/uclibc_0.9.30.1.bb
@@ -14,16 +14,16 @@ PR = "${INC_PR}.4"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
SRC_URI += "file://uClibc.machine file://uClibc.distro \
- file://arm-linuxthreads.patch;apply=yes \
- file://linuxthreads-changes.patch;apply=yes \
- file://pthread_atfork.patch;apply=yes \
- file://uclibc_ldso_use_O0.patch;apply=yes \
- file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;apply=yes \
- file://gcc-4.4-fixlet.patch;apply=yes \
- file://uclibc-c99-ldbl-math.patch;apply=yes \
- file://Use-__always_inline-instead-of-__inline__.patch;apply=yes \
- file://installfix.patch;apply=yes \
- file://o_cloexec.patch;apply=yes \
+ file://arm-linuxthreads.patch \
+ file://linuxthreads-changes.patch \
+ file://pthread_atfork.patch \
+ file://uclibc_ldso_use_O0.patch \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
+ file://gcc-4.4-fixlet.patch \
+ file://uclibc-c99-ldbl-math.patch \
+ file://Use-__always_inline-instead-of-__inline__.patch \
+ file://installfix.patch \
+ file://o_cloexec.patch \
"
#recent versions uclibc require real kernel headers
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/uclibc/uclibc_0.9.30.2.bb b/recipes/uclibc/uclibc_0.9.30.2.bb
index ea94db1d18..f3ba501a0a 100644
--- a/recipes/uclibc/uclibc_0.9.30.2.bb
+++ b/recipes/uclibc/uclibc_0.9.30.2.bb
@@ -14,11 +14,11 @@ PR = "${INC_PR}.0"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
SRC_URI += "file://uClibc.machine file://uClibc.distro \
- file://pthread_atfork.patch;apply=yes \
- file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;apply=yes \
- file://installfix.patch;apply=yes \
- file://o_cloexec.patch;apply=yes \
- file://uclibc_fix_mips_crt.patch;apply=yes \
+ file://pthread_atfork.patch \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
+ file://installfix.patch \
+ file://o_cloexec.patch \
+ file://uclibc_fix_mips_crt.patch \
"
SRC_URI[uClibc-0.9.30.2.md5sum] = "e759ec855500082ac3e671dd6cacfdb0"
SRC_URI[uClibc-0.9.30.2.sha256sum] = "ab6e92c91e2f8fad182d3b624b87d6cbf53072678d8fc31ad73e6abd3c852473"
diff --git a/recipes/uclibc/uclibc_0.9.30.3.bb b/recipes/uclibc/uclibc_0.9.30.3.bb
index 6f66fc8703..2f5f23c05d 100644
--- a/recipes/uclibc/uclibc_0.9.30.3.bb
+++ b/recipes/uclibc/uclibc_0.9.30.3.bb
@@ -14,7 +14,7 @@ PR = "${INC_PR}.0"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
SRC_URI += "file://uClibc.machine file://uClibc.distro \
- file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;apply=yes \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
"
#recent versions uclibc require real kernel headers
diff --git a/recipes/uclibc/uclibc_0.9.30.bb b/recipes/uclibc/uclibc_0.9.30.bb
index a4f8a8134a..5d267b560c 100644
--- a/recipes/uclibc/uclibc_0.9.30.bb
+++ b/recipes/uclibc/uclibc_0.9.30.bb
@@ -14,13 +14,13 @@ PR = "${INC_PR}.1"
PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
SRC_URI += "file://uClibc.machine file://uClibc.distro \
- file://arm-linuxthreads.patch;apply=yes \
- file://linuxthreads-changes.patch;apply=yes \
- file://pthread_atfork.patch;apply=yes \
- file://uclibc_ldso_use_O0.patch;apply=yes \
- file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;apply=yes \
- file://unifdef-fix.patch;apply=yes \
- file://Use-__always_inline-instead-of-__inline__.patch;apply=yes \
+ file://arm-linuxthreads.patch \
+ file://linuxthreads-changes.patch \
+ file://pthread_atfork.patch \
+ file://uclibc_ldso_use_O0.patch \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
+ file://unifdef-fix.patch \
+ file://Use-__always_inline-instead-of-__inline__.patch \
"
#recent versions uclibc require real kernel headers
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/uclibc/uclibc_git.bb b/recipes/uclibc/uclibc_git.bb
index 842e431079..31e8924328 100644
--- a/recipes/uclibc/uclibc_git.bb
+++ b/recipes/uclibc/uclibc_git.bb
@@ -30,8 +30,8 @@ SRC_URI = "git://uclibc.org/uClibc.git;branch=master;protocol=git \
file://uClibc.config \
file://uClibc.machine \
file://uClibc.distro \
- file://uclibc-arm-ftruncate64.patch;apply=yes \
- file://uclibc_enable_log2_test.patch;apply=yes \
- file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;apply=yes \
+ file://uclibc-arm-ftruncate64.patch \
+ file://uclibc_enable_log2_test.patch \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
"
S = "${WORKDIR}/git"