aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev_124.bb
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-23 10:07:37 +1030
committerEric Bénard <eric@eukrea.com>2010-11-28 10:49:40 +0100
commitc3642f0b09467c5738b8232521c2a37f05c7ee66 (patch)
treef80753e22daf33b6069b11d42b6daed53b9c8f6f /recipes/udev/udev_124.bb
parent40d081740d35a454181a6389f1b1f85a0c9ce8e1 (diff)
downloadopenembedded-c3642f0b09467c5738b8232521c2a37f05c7ee66.tar.gz
udev_124.bb: Fix build when DISTRO_FEATURES lacks "largefile".
NOTE: make -e EXTRAS=extras/firmware/ extras/scsi_id/ extras/volume_id/ STRIP=echo libudevdir=/lib/udev libdir=/lib prefix= GENHDR udev_version.h CC udev_device.o In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdlib.h:25:0, from udev_device.c:20: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/features.h:216:5: error: #error It appears you have defined _FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file support enabled. In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:72:0, from udev_device.c:21: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/bits/uClibc_stdio.h:61:2: error: #error Sorry... uClibc was built without large file support! In file included from udev_device.c:21:0: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:83:26: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'fpos_t' In file included from udev_device.c:21:0: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:719:12: error: expected declaration specifiers or '...' before 'fpos_t' /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/stdio.h:721:12: error: expected ';', ',' or ')' before '*' token udev_device.c: In function 'udev_device_event': udev_device.c:272:4: warning: cast increases required alignment of target type udev_device.c:272:4: warning: cast increases required alignment of target type make: *** [udev_device.o] Error 1 FATAL: oe_runmake failed Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/udev/udev_124.bb')
-rw-r--r--recipes/udev/udev_124.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/udev/udev_124.bb b/recipes/udev/udev_124.bb
index d0d54206dc..a6c0e18dc3 100644
--- a/recipes/udev/udev_124.bb
+++ b/recipes/udev/udev_124.bb
@@ -29,6 +29,10 @@ FILES_${PN}-dbg += "${base_libdir}/udev/.debug"
UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/"
EXTRA_OEMAKE += "libudevdir=/lib/udev libdir=${base_libdir} prefix="
+do_configure_prepend_libc-uclibc() {
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/Makefile', d)}"
+}
+
do_install () {
install -d ${D}${usrsbindir} \
${D}${sbindir}