aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/webm
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-09-23 14:47:32 -0400
committerMichael Smith <msmith@cbnco.com>2010-09-27 07:54:54 -0400
commit96eb8296fea83132afcca2bfccf2de2c9f03e211 (patch)
treedb664126c0ba7ac0cc3eded2d9b59d820595887b /recipes/webm
parent3619711f4c1c3e99d542801259d029e74a8cab8b (diff)
downloadopenembedded-96eb8296fea83132afcca2bfccf2de2c9f03e211.tar.gz
libvpx: fix 0.9.1 build when prefix=""
The configure script was changed in 0.9.1 and introduced some logic that breaks when prefix is an empty string. Also switch to INC_PR for 0.9.0 and 0.9.1. Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/webm')
-rw-r--r--recipes/webm/libvpx-0.9.1/libvpx-configure-support-blank-prefix.patch43
-rw-r--r--recipes/webm/libvpx.inc2
-rw-r--r--recipes/webm/libvpx_0.9.0.bb2
-rw-r--r--recipes/webm/libvpx_0.9.1.bb9
4 files changed, 54 insertions, 2 deletions
diff --git a/recipes/webm/libvpx-0.9.1/libvpx-configure-support-blank-prefix.patch b/recipes/webm/libvpx-0.9.1/libvpx-configure-support-blank-prefix.patch
new file mode 100644
index 0000000000..1bf863dfa2
--- /dev/null
+++ b/recipes/webm/libvpx-0.9.1/libvpx-configure-support-blank-prefix.patch
@@ -0,0 +1,43 @@
+Upstream: not yet
+
+Fix configure to accept "--prefix=" (a blank prefix).
+
+--- libvpx-0.9.1/build/make/configure.sh.orig 2010-06-17 09:08:56.000000000 -0400
++++ libvpx-0.9.1/build/make/configure.sh 2010-09-23 14:27:48.000000000 -0400
+@@ -444,6 +444,8 @@
+ ;;
+ --prefix=*)
+ prefix="${optval}"
++ # Distinguish between "prefix not set" and "prefix set to ''"
++ prefixset=1
+ ;;
+ --libdir=*)
+ libdir="${optval}"
+@@ -471,13 +473,23 @@
+
+
+ post_process_common_cmdline() {
+- prefix="${prefix:-/usr/local}"
++ if [ "$prefixset" != "1" ]
++ then
++ prefix=/usr/local
++ fi
++
++ # Strip trailing slash
+ prefix="${prefix%/}"
++
+ libdir="${libdir:-${prefix}/lib}"
+ libdir="${libdir%/}"
+- if [ "${libdir#${prefix}}" = "${libdir}" ]; then
+- die "Libdir ${libdir} must be a subdirectory of ${prefix}"
+- fi
++
++ case "$libdir" in
++ "${prefix}/"*) ;;
++ *)
++ die "Libdir ${libdir} must be a subdirectory of ${prefix}"
++ ;;
++ esac
+ }
+
+
diff --git a/recipes/webm/libvpx.inc b/recipes/webm/libvpx.inc
index a0aebffc17..d773d3ab70 100644
--- a/recipes/webm/libvpx.inc
+++ b/recipes/webm/libvpx.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "vpx Multi-Format Codec SDK"
LICENSE = "BSD"
-PR = "r1"
+INC_PR = "r4"
SRC_URI = "http://webm.googlecode.com/files/libvpx-${PV}.tar.bz2"
diff --git a/recipes/webm/libvpx_0.9.0.bb b/recipes/webm/libvpx_0.9.0.bb
index 8992c04b8a..3447c6f2c9 100644
--- a/recipes/webm/libvpx_0.9.0.bb
+++ b/recipes/webm/libvpx_0.9.0.bb
@@ -2,7 +2,7 @@ require libvpx.inc
LICENSE = "VP8"
-PR = "r3"
+PR = "${INC_PR}.0"
SRC_URI[md5sum] = "9eb8e818d2f3263623c258fe66924082"
SRC_URI[sha256sum] = "a0096ac6859cfb61cf06dd9bc0a79a3333a4ec389ba311911d84df8ff2a1b9dc"
diff --git a/recipes/webm/libvpx_0.9.1.bb b/recipes/webm/libvpx_0.9.1.bb
index b5471b8257..bcb73587d3 100644
--- a/recipes/webm/libvpx_0.9.1.bb
+++ b/recipes/webm/libvpx_0.9.1.bb
@@ -1,5 +1,14 @@
require libvpx.inc
+PR = "${INC_PR}.0"
+
+SRC_URI += "file://libvpx-configure-support-blank-prefix.patch;apply=yes"
+
+CONFIGUREOPTS += " \
+ --prefix=${prefix} \
+ --libdir=${libdir} \
+"
+
SRC_URI[md5sum] = "e1442e74d0cca228785083fa520735a2"
SRC_URI[sha256sum] = "c4e8e463e079ffde5b6948366a1d0873f1bf685dccd89ca137585c2b8247ec59"