aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xboard
diff options
context:
space:
mode:
authorTom Hacohen <tom@stosb.com>2009-11-21 12:40:01 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-11-21 15:00:54 +0100
commit05cb1bdc81e21e6039dc65e007a151e85286229c (patch)
treea48bf2b8abaf21dda262a30f6ed01b480dd6fb54 /recipes/xboard
parent238eb99969e0005817ae05df316e5de814d5fcfd (diff)
downloadopenembedded-05cb1bdc81e21e6039dc65e007a151e85286229c.tar.gz
Updated xboard's recipe and patch to the newest version Removed old recipe as the sources are not available any more
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/xboard')
-rw-r--r--recipes/xboard/files/no-strip.patch33
-rw-r--r--recipes/xboard/xboard_4.4.1.bb (renamed from recipes/xboard/xboard_4.2.7.bb)6
2 files changed, 23 insertions, 16 deletions
diff --git a/recipes/xboard/files/no-strip.patch b/recipes/xboard/files/no-strip.patch
index 5785a9a1f1..7fb8cd5dc5 100644
--- a/recipes/xboard/files/no-strip.patch
+++ b/recipes/xboard/files/no-strip.patch
@@ -1,15 +1,22 @@
-Index: xboard-4.2.7-r0/xboard-4.2.7/Makefile.in
+Index: xboard-4.4.1-r0/xboard-4.4.1/Makefile.in
===================================================================
---- xboard-4.2.7-r0.orig/xboard-4.2.7/Makefile.in
-+++ xboard-4.2.7-r0/xboard-4.2.7/Makefile.in
-@@ -63,8 +63,8 @@ default: xboard zic2xpm
- all: default pseudosource info FAQ html dvi ps
+--- xboard-4.4.1-r0.orig/xboard-4.4.1/Makefile.in
++++ xboard-4.4.1-r0/xboard-4.4.1/Makefile.in
+@@ -939,7 +939,7 @@
- install: installdirs default
-- $(INSTALL_PROGRAM) -s xboard $(bindir)/xboard
-- $(INSTALL_PROGRAM) -s zic2xpm $(bindir)/zic2xpm
-+ $(INSTALL_PROGRAM) xboard $(bindir)/xboard
-+ $(INSTALL_PROGRAM) zic2xpm $(bindir)/zic2xpm
- $(INSTALL_PROGRAM) cmail $(bindir)/cmail
- $(INSTALL_PROGRAM) $(srcdir)/pxboard $(bindir)/pxboard
- $(INSTALL_DATA) $(srcdir)/xboard.man $(man6dir)/xboard$(man6ext)
+ uninstall-man: uninstall-man6
+
+-.MAKE: install-am install-strip
++.MAKE: install-am
+
+ .PHONY: CTAGS GTAGS all all-am am--refresh check check-am clean \
+ clean-binPROGRAMS clean-generic ctags dist dist-all dist-bzip2 \
+@@ -951,7 +951,7 @@
+ install-data-am install-dvi install-dvi-am install-exec \
+ install-exec-am install-html install-html-am install-info \
+ install-info-am install-man install-man6 install-pdf \
+- install-pdf-am install-ps install-ps-am install-strip \
++ install-pdf-am install-ps install-ps-am \
+ installcheck installcheck-am installdirs maintainer-clean \
+ maintainer-clean-aminfo maintainer-clean-generic \
+ maintainer-clean-vti mostlyclean mostlyclean-aminfo \
diff --git a/recipes/xboard/xboard_4.2.7.bb b/recipes/xboard/xboard_4.4.1.bb
index 1b5a4129a2..0c31b9ced3 100644
--- a/recipes/xboard/xboard_4.2.7.bb
+++ b/recipes/xboard/xboard_4.4.1.bb
@@ -3,11 +3,11 @@ HOMEPAGE = "http://www.tim-mann.org/xboard.html"
SECTION = "games"
LICENSE = "GPL"
DEPENDS = "libxaw libsm libx11 libxt libxmu libxext libice"
-SRC_URI = "http://ftp.gnu.org/gnu/xboard/xboard-4.2.7.tar.gz \
- file://no-strip.patch;patch=1;pnum=2"
+SRC_URI = "http://ftp.gnu.org/gnu/xboard/xboard-${PV}.tar.gz \
+ file://no-strip.patch;patch=1;pnum=2"
inherit autotools
do_configure() {
- oe_runconf --exec-prefix=${D}/${prefix} --prefix=${D}/${prefix} --bindir=${D}/${bindir} --mandir=${D}/${mandir}
+ oe_runconf --exec-prefix=${prefix} --prefix=${D}/${prefix} --bindir=${bindir} --mandir=${D}/${mandir}
}