aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xcb
diff options
context:
space:
mode:
authorVladimir Zapolskiy <vzapolskiy@gmail.com>2010-06-04 16:30:08 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-04 16:44:19 +0400
commit52b03b11c03899be56ca632411b2e61ac9670554 (patch)
treebcec416ea4677dd9fa960aaea73db1f3537ec8bb /recipes/xcb
parentc65ee13298e8c22274b5bcabe06f2116b8b7ebf2 (diff)
downloadopenembedded-52b03b11c03899be56ca632411b2e61ac9670554.tar.gz
libxcb: fix paths for installed python modules
This fixes a compilation problem for recent libxcb versions, providing correct paths to the installed python modules. Signed-off-by: Vladimir Zapolskiy <vzapolskiy@gmail.com> Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/xcb')
-rw-r--r--recipes/xcb/libxcb/configure_git.patch20
-rw-r--r--recipes/xcb/libxcb_git.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/xcb/libxcb/configure_git.patch b/recipes/xcb/libxcb/configure_git.patch
new file mode 100644
index 0000000000..5dc9f91129
--- /dev/null
+++ b/recipes/xcb/libxcb/configure_git.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac 2010-06-04 13:45:24.312592212 +0400
++++ b/configure.ac 2010-06-04 13:47:09.468417189 +0400
+@@ -54,7 +54,7 @@
+
+ # Find the xcb-proto protocol descriptions
+ AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
+-XCBPROTO_XCBINCLUDEDIR=`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
++XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR}`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
+ AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
+
+@@ -64,7 +64,7 @@
+
+ # Find the xcbgen Python package
+ AC_MSG_CHECKING(XCBPROTO_XCBPYTHONDIR)
+-XCBPROTO_XCBPYTHONDIR=`$PKG_CONFIG --variable=pythondir xcb-proto`
++XCBPROTO_XCBPYTHONDIR=${STAGING_DIR}`$PKG_CONFIG --variable=pythondir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBPYTHONDIR)
+ AC_SUBST(XCBPROTO_XCBPYTHONDIR)
+
diff --git a/recipes/xcb/libxcb_git.bb b/recipes/xcb/libxcb_git.bb
index 770c18f179..cf728e7817 100644
--- a/recipes/xcb/libxcb_git.bb
+++ b/recipes/xcb/libxcb_git.bb
@@ -7,7 +7,8 @@ PR = "r0"
DEPENDS += "libpthread-stubs"
-SRC_URI = "git://anongit.freedesktop.org/xcb/libxcb;protocol=git"
+SRC_URI = "git://anongit.freedesktop.org/xcb/libxcb;protocol=git \
+ file://configure_git.patch "
S = "${WORKDIR}/git"
PACKAGES =+ "libxcb-xinerama"