aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base/libxfce4util_4.4.2.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-25 10:52:51 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-27 15:26:58 +0100
commitcf508f496dae24acc1b4fd3cecb5dd191b5d69b6 (patch)
tree0138c2b6b924c7426a510404256173adca53e8e6 /recipes/xfce-base/libxfce4util_4.4.2.bb
parenteeac84ae328fa18770c3724a23ff847f954f60dc (diff)
downloadopenembedded-cf508f496dae24acc1b4fd3cecb5dd191b5d69b6.tar.gz
XFCE: Rename xfce to xfce-base to support the import of the new XFCE 4.6.1 builds.
Diffstat (limited to 'recipes/xfce-base/libxfce4util_4.4.2.bb')
-rw-r--r--recipes/xfce-base/libxfce4util_4.4.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/xfce-base/libxfce4util_4.4.2.bb b/recipes/xfce-base/libxfce4util_4.4.2.bb
new file mode 100644
index 0000000000..3386ad57e3
--- /dev/null
+++ b/recipes/xfce-base/libxfce4util_4.4.2.bb
@@ -0,0 +1,26 @@
+# libxfce4util OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xfce4-dev-tools"
+
+inherit xfce pkgconfig
+
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
+ # The line below expands to the list of headers that native makefile
+ # would install. Complain and/or fix if it's not portable enough
+ for file in $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+
+}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"