aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base/xfwm4-themes_4.4.2.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-25 10:52:51 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-27 15:26:58 +0100
commitcf508f496dae24acc1b4fd3cecb5dd191b5d69b6 (patch)
tree0138c2b6b924c7426a510404256173adca53e8e6 /recipes/xfce-base/xfwm4-themes_4.4.2.bb
parenteeac84ae328fa18770c3724a23ff847f954f60dc (diff)
downloadopenembedded-cf508f496dae24acc1b4fd3cecb5dd191b5d69b6.tar.gz
XFCE: Rename xfce to xfce-base to support the import of the new XFCE 4.6.1 builds.
Diffstat (limited to 'recipes/xfce-base/xfwm4-themes_4.4.2.bb')
-rw-r--r--recipes/xfce-base/xfwm4-themes_4.4.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/xfce-base/xfwm4-themes_4.4.2.bb b/recipes/xfce-base/xfwm4-themes_4.4.2.bb
new file mode 100644
index 0000000000..63c5ab0296
--- /dev/null
+++ b/recipes/xfce-base/xfwm4-themes_4.4.2.bb
@@ -0,0 +1,18 @@
+# xfwm4-themes OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION="XFCE4 Window Manager Themes"
+SECTION = "x11/wm"
+
+inherit xfce
+
+# No ${PN} for this one
+PACKAGES=""
+
+PACKAGES_DYNAMIC = "xfwm4-theme-*"
+
+python populate_packages_prepend () {
+ themedir = bb.data.expand('${datadir}/xfwm4/themes', d)
+ do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
+}