aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfsprogs
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-10 13:13:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-10 13:15:12 +0200
commit27870493b20c1720c98969e3f0e821580c5a2d8a (patch)
treee796dba5c3dc14b2e93731adf8d3baa458819433 /recipes/xfsprogs
parent5e69441e65ab763153363cfcb6ba2079e016bced (diff)
downloadopenembedded-27870493b20c1720c98969e3f0e821580c5a2d8a.tar.gz
xfsprogs: add 3.1.2 version
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xfsprogs')
-rw-r--r--recipes/xfsprogs/xfsprogs_3.1.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/xfsprogs/xfsprogs_3.1.2.bb b/recipes/xfsprogs/xfsprogs_3.1.2.bb
new file mode 100644
index 0000000000..736d458ec5
--- /dev/null
+++ b/recipes/xfsprogs/xfsprogs_3.1.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "XFS Filesystem Utilities"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+LICENSE = "GPL"
+SECTION = "base"
+DEPENDS = "util-linux-ng"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz"
+SRC_URI[md5sum] = "86d10178ee6897cb099c97303e6d9da0"
+SRC_URI[sha256sum] = "9128046ea978a65560b0e87406af9646a283fa0b54eab1801b971d8a89086ddd"
+
+PARALLEL_MAKE = ""
+inherit autotools
+EXTRA_OECONF = "--enable-gettext=no"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+
+do_configure () {
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+}
+