aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xl2tpd
diff options
context:
space:
mode:
authorVladimir Sorokin <sorokin@altell.ru>2010-05-07 14:41:15 +0400
committerRoman I Khimov <khimov@altell.ru>2010-06-07 00:09:19 +0400
commitbb70fcdfae337cef75e952519fb1db5acac9e62f (patch)
tree8d84b97163840483b69eae60ec11b89cbdc12408 /recipes/xl2tpd
parent0e0f79d08fe1ed4c081080425f6fefacd4b14e26 (diff)
downloadopenembedded-bb70fcdfae337cef75e952519fb1db5acac9e62f.tar.gz
xl2tpd: Initial commit.
Layer 2 Tunneling Protocol (L2TP) daemon. Signed-off-by: Vladimir Sorokin <sorokin@altell.ru> Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/xl2tpd')
-rw-r--r--recipes/xl2tpd/xl2tpd.inc27
-rw-r--r--recipes/xl2tpd/xl2tpd_1.2.4.bb6
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes/xl2tpd/xl2tpd.inc b/recipes/xl2tpd/xl2tpd.inc
new file mode 100644
index 0000000000..da47d7e90b
--- /dev/null
+++ b/recipes/xl2tpd/xl2tpd.inc
@@ -0,0 +1,27 @@
+DEPENDS += "virtual/libc ppp"
+DESCRIPTION = " version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.xelerance.com/software/xl2tpd/"
+SECTION = "network"
+
+INC_PR = "r0"
+
+SRC_URI = "http://www.xelerance.com/software/xl2tpd/xl2tpd-${PV}.tar.gz"
+
+S = "${WORKDIR}/xl2tpd-${PV}"
+
+do_compile () {
+ oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" all
+}
+
+do_install () {
+ oe_runmake PREFIX="${D}${prefix}" install
+
+ install -d ${D}${sysconfdir}/init.d
+ touch ${D}${sysconfdir}/xl2tpd.conf
+ install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd"
diff --git a/recipes/xl2tpd/xl2tpd_1.2.4.bb b/recipes/xl2tpd/xl2tpd_1.2.4.bb
new file mode 100644
index 0000000000..7796b6e5b1
--- /dev/null
+++ b/recipes/xl2tpd/xl2tpd_1.2.4.bb
@@ -0,0 +1,6 @@
+PR = "${INC_PR}.0"
+require xl2tpd.inc
+
+SRC_URI[md5sum] = "d94fc8a13596f12a561240dfcea9f977"
+SRC_URI[sha256sum] = "3e6b4314a5100a576dd075684873b1e8b84b58f7f5ceb10731fabd3ebefaa8c4"
+