aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorChristian Charreyre <christian.charreyre@cioinfoindus.fr>2011-04-29 17:43:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-19 09:51:44 +0200
commit3a50b954d8c832782d9b9d29ff181d8a54a5e9e5 (patch)
treecffea8ca4198345d58e868d5ce9d3ecbf827bf62 /recipes
parent2fb2df92fd0d6c1238c2fa19a1c1b2f624c6fc15 (diff)
downloadopenembedded-3a50b954d8c832782d9b9d29ff181d8a54a5e9e5.tar.gz
python-numpy: add missing runtime dependencies
Without these runtime dependencies there are errors on the target when executing `mypaint`, because `python-numpy` code calls `import` from the distinct packages. TODO: It is not clear where this error originates from and what the best fix is. There are the following alternatives. 1. Add the runtime dependencies to `mypaint`. 2. Add these packages to `RRECOMMENDS`. This patch is build tested using `angstrom-2010.x` for `MACHINE = "beagleboard"`. Signed-off-by: Christian Charreyre <christian.charreyre@cioinfoindus.fr> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python-numpy_1.1.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes/python/python-numpy_1.1.1.bb b/recipes/python/python-numpy_1.1.1.bb
index f5c23e055f..8594ea00b5 100644
--- a/recipes/python/python-numpy_1.1.1.bb
+++ b/recipes/python/python-numpy_1.1.1.bb
@@ -4,6 +4,8 @@ PRIORITY = "optional"
LICENSE = "PSF"
PR = "ml0"
+RDEPENDS_${PN} = "python-compiler python-mmap python-pkgutil python-pydoc python-unittest"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
file://unbreak-assumptions.diff \
file://trycompile.diff \