aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/e-wm_svn.bb9
-rw-r--r--recipes/e17/elfe_svn.bb6
-rw-r--r--recipes/e17/enjoy_svn.bb4
-rw-r--r--recipes/e17/ephoto_svn.bb14
-rw-r--r--recipes/e17/eve/0001-eve-remove-unconditional-ewk_view_context_menu_forwa.patch34
-rw-r--r--recipes/e17/eve_svn.bb4
-rw-r--r--recipes/e17/illume-keyboards-shr/LICENSE25
-rw-r--r--recipes/e17/illume-keyboards-shr_git.bb6
8 files changed, 91 insertions, 11 deletions
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index e8f6b1eab9..04996b38ad 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -1,12 +1,13 @@
DESCRIPTION = "The Enlightenment Window Manager Version 17"
DEPENDS = "eet evas ecore edje efreet edbus eeze"
LICENSE = "MIT BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f523ab5986cc79b52a90d2ac3d5454a2"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r18"
+PR = "r20"
SRCREV = "${EFL_SRCREV}"
-inherit e update-alternatives
+inherit e update-alternatives gettext
S = "${WORKDIR}/${SRCNAME}"
SRC_URI = "\
@@ -91,13 +92,15 @@ PACKAGES =+ "\
illume-keyboard-default-terminal \
"
+ESYSACTIONS ?= "${PN}-sysactions"
+
RRECOMMENDS_${PN} = "\
${PN}-config-default \
${PN}-images \
${PN}-icons \
${PN}-other \
${PN}-input-methods \
- ${PN}-sysactions \
+ ${ESYSACTIONS} \
"
PACKAGE_ARCH_${PN}-config-default = "all"
diff --git a/recipes/e17/elfe_svn.bb b/recipes/e17/elfe_svn.bb
index af0ed7c6d9..f2878a15cc 100644
--- a/recipes/e17/elfe_svn.bb
+++ b/recipes/e17/elfe_svn.bb
@@ -6,7 +6,7 @@ require e-module.inc
DEPENDS += "elementary"
-# Elfe is part of the enlightenment svn repository since this SRC_REV. As EFL_SRCREV is
-# currently much older we need to sync it when EFL_SRCREV will change.
-SRCREV = "57458"
+# We currently use another SRCREV for elfe as EFL_SRCREV as we have to change it more
+# often than we want to change EFL_SRCREV.
+SRCREV = "60365"
diff --git a/recipes/e17/enjoy_svn.bb b/recipes/e17/enjoy_svn.bb
index eab81b4c5a..d709eb7814 100644
--- a/recipes/e17/enjoy_svn.bb
+++ b/recipes/e17/enjoy_svn.bb
@@ -3,7 +3,7 @@ LICENSE = "LGPLv3"
DEPENDS = "evas ecore edje elementary emotion lightmediascanner"
SRCREV = "${EFL_SRCREV}"
PV = "0.0+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
DEPENDS += "gst-plugins-good ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugins-ugly', d)}"
@@ -13,7 +13,7 @@ DEPENDS += "gst-plugins-good ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '
#4th needed for flac playback
#5th needed binary to create db
RDEPENDS += "\
- gst-plugin-typefindfunctions gst-plugin-playbin gst-plugin-volume gst-plugin-decodebin2 \
+ gst-plugin-typefindfunctions gst-plugin-playbin gst-plugin-volume gst-plugin-decodebin2 gst-plugin-alsa gst-plugin-autodetect \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad gst-plugin-id3demux', d)} \
gst-plugin-ogg gst-plugin-ivorbisdec \
gst-plugin-flac \
diff --git a/recipes/e17/ephoto_svn.bb b/recipes/e17/ephoto_svn.bb
new file mode 100644
index 0000000000..469439884e
--- /dev/null
+++ b/recipes/e17/ephoto_svn.bb
@@ -0,0 +1,14 @@
+LICENSE = "MIT CC-BY-SA2.5"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "${INC_PR}.0"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=df45d9de58df0b48f515eae8d2421257"
+LIC_FILES_CHKSUM = "file://COPYING.icons;md5=d4e4f10748f3146a089aaa23c9ade59b"
+
+require e-module.inc
+
+inherit gettext
+
+DEPENDS += "elementary ethumb ecore eio"
+
+SRCNAME = "${PN}"
diff --git a/recipes/e17/eve/0001-eve-remove-unconditional-ewk_view_context_menu_forwa.patch b/recipes/e17/eve/0001-eve-remove-unconditional-ewk_view_context_menu_forwa.patch
new file mode 100644
index 0000000000..bb86e98279
--- /dev/null
+++ b/recipes/e17/eve/0001-eve-remove-unconditional-ewk_view_context_menu_forwa.patch
@@ -0,0 +1,34 @@
+From cff40dddea01d217fc3789c2c8e3337ea2ec34b7 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Mon, 21 Feb 2011 10:29:47 +0100
+Subject: [PATCH] eve: remove unconditional ewk_view_context_menu_forward_event call
+
+* ewk_view_context_menu_forward_event is not available in ewebkit lib (only in API)
+ after https://bugs.webkit.org/show_bug.cgi?id=51530
+---
+ src/bin/view.c | 9 +++++++--
+ 1 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/src/bin/view.c b/src/bin/view.c
+index d743d75..5493b20 100644
+--- a/src/bin/view.c
++++ b/src/bin/view.c
+@@ -1200,8 +1200,13 @@ _view_smart_mouse_down(Ewk_View_Smart_Data *esd, const Evas_Event_Mouse_Down *ev
+ return EINA_TRUE;
+
+ forward_event:
+- if (ev->button == 3) // forward of context menu event is special
+- return ewk_view_context_menu_forward_event(sd->base.self, ev);
++ /* https://bugs.webkit.org/show_bug.cgi?id=51530
++ * made ewk_view_context_menu_forward_event conditionally available
++ * but didn't change it in ewk_view.h, so this compiles fine, but later
++ * linker fails. Remove this part here temporary before proper solution is found
++ * if (ev->button == 3) // forward of context menu event is special
++ * return ewk_view_context_menu_forward_event(sd->base.self, ev);
++ */
+
+ /* If we should forward/feed event using parent class method, then
+ * just do it and do NOT create an animator. See _view_smart_mouse_up().
+--
+1.7.4.1
+
diff --git a/recipes/e17/eve_svn.bb b/recipes/e17/eve_svn.bb
index d7f93e9907..d324c55d27 100644
--- a/recipes/e17/eve_svn.bb
+++ b/recipes/e17/eve_svn.bb
@@ -2,13 +2,15 @@ DESCRIPTION = " Enlightenment Web Browser"
LICENSE = "GPL"
DEPENDS = "evas ecore edje elementary webkit-efl"
PV = "0.3.0.0+svnr${SRCPV}"
+PR = "r1"
SRCREV = "${EFL_SRCREV}"
inherit e
SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
S = "${WORKDIR}/${SRCNAME}"
-SRC_URI += "file://eve-theme-for-smaller-screens.patch"
+SRC_URI += "file://eve-theme-for-smaller-screens.patch \
+ file://0001-eve-remove-unconditional-ewk_view_context_menu_forwa.patch"
EXTRA_OECONF = "\
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
diff --git a/recipes/e17/illume-keyboards-shr/LICENSE b/recipes/e17/illume-keyboards-shr/LICENSE
new file mode 100644
index 0000000000..61bb2f603d
--- /dev/null
+++ b/recipes/e17/illume-keyboards-shr/LICENSE
@@ -0,0 +1,25 @@
+Copyright notice for Enlightenment:
+
+Copyright (C) 2000-2010 Carsten Haitzler and various contributors (see AUTHORS)
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
+INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
+FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA,
+OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/recipes/e17/illume-keyboards-shr_git.bb b/recipes/e17/illume-keyboards-shr_git.bb
index 302dbd8d24..e3b182dea6 100644
--- a/recipes/e17/illume-keyboards-shr_git.bb
+++ b/recipes/e17/illume-keyboards-shr_git.bb
@@ -1,14 +1,16 @@
SECTION = "x11/data"
SRC_URI = "git://git.shr-project.org/repo/illume-keyboards.git;protocol=http;branch=master \
- file://0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch"
+ file://0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch \
+ file://LICENSE"
S = "${WORKDIR}/git"
SRCREV = "4064489f359a1addf572089b582f317dff5f50e1"
PV = "0.0+gitr${SRCPV}"
PE = "1"
PR = "r4"
-
+LICENSE = "MIT BSD"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=f523ab5986cc79b52a90d2ac3d5454a2"
PACKAGES = "\
illume-keyboard-alpha \