aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffmpeg/ffmpeg-0.4.9-pre1
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ffmpeg/ffmpeg-0.4.9-pre1')
-rw-r--r--recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-add-liblame.patch13
-rw-r--r--recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-avformat-use-LDFLAGS.patch13
-rw-r--r--recipes/ffmpeg/ffmpeg-0.4.9-pre1/configure.patch113
-rw-r--r--recipes/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch146
-rw-r--r--recipes/ffmpeg/ffmpeg-0.4.9-pre1/install-must-not-strip.patch47
-rw-r--r--recipes/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch84
6 files changed, 416 insertions, 0 deletions
diff --git a/recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-add-liblame.patch b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-add-liblame.patch
new file mode 100644
index 0000000000..3c3969de43
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-add-liblame.patch
@@ -0,0 +1,13 @@
+--- /orig-Makefile 2008-07-17 00:29:01.000000000 +0300
++++ /Makefile 2008-07-17 00:29:35.000000000 +0300
+@@ -58,6 +58,10 @@
+ EXTRALIBS+=-lfaac
+ endif
+
++ifeq ($(CONFIG_MP3LAME),yes)
++EXTRALIBS+=-lmp3lame
++endif
++
+ ifeq ($(BUILD_VHOOK),yes)
+ VHOOK=videohook
+ INSTALLVHOOK=install-vhook
diff --git a/recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-avformat-use-LDFLAGS.patch b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-avformat-use-LDFLAGS.patch
new file mode 100644
index 0000000000..d78ada9b36
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/Makefile-avformat-use-LDFLAGS.patch
@@ -0,0 +1,13 @@
+Index: ffmpeg-0.4.9-pre1/libavformat/Makefile
+===================================================================
+--- ffmpeg-0.4.9-pre1.orig/libavformat/Makefile 2008-08-30 11:35:09.000000000 +0200
++++ ffmpeg-0.4.9-pre1/libavformat/Makefile 2008-08-30 11:35:34.000000000 +0200
+@@ -94,7 +94,7 @@
+ $(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) $(VPATH)/../libavcodec/avcodec.dll
+ -lib /machine:i386 /def:$(@:.dll=.def)
+ else
+- $(CC) $(SHFLAGS) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) -Wl,-soname -Wl,libavformat.so.0
++ $(CC) $(SHFLAGS) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) $(LDFLAGS) -Wl,-soname -Wl,libavformat.so.0
+ endif
+
+ depend: $(SRCS)
diff --git a/recipes/ffmpeg/ffmpeg-0.4.9-pre1/configure.patch b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/configure.patch
new file mode 100644
index 0000000000..10fa0ce6b2
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/configure.patch
@@ -0,0 +1,113 @@
+--- ./configure~configure.patch 2004-07-06 03:36:16.000000000 +0930
++++ ./configure 2004-09-27 00:07:23.000000000 +0930
+@@ -88,7 +88,7 @@
+ mandir=""
+ bindir=""
+ cross_prefix=""
+-cc="gcc"
++cc="$CC"
+ ar="ar"
+ ranlib="ranlib"
+ make="make"
+@@ -104,7 +104,7 @@
+ cpu="x86"
+ ;;
+ # armv4l is a subset of armv5tel
+- armv4l|armv5tel)
++ armv4l|armv5tel|arm|xscale)
+ cpu="armv4l"
+ ;;
+ alpha)
+@@ -434,6 +434,37 @@
+ esac
+ done
+
++case "$cpu" in
++ i386|i486|i586|i686|i86pc|BePC)
++ cpu="x86"
++ ;;
++ # armv4l is a subset of armv5tel
++ armv4l|armv5tel|arm|xscale)
++ cpu="armv4l"
++ ;;
++ alpha)
++ cpu="alpha"
++ ;;
++ "Power Macintosh"|ppc)
++ cpu="powerpc"
++ ;;
++ mips)
++ cpu="mips"
++ ;;
++ sun4u|sparc64)
++ cpu="sparc64"
++ ;;
++ sparc)
++ cpu="sparc"
++ ;;
++ sh4)
++ cpu="sh4"
++ ;;
++ *)
++ cpu="unknown"
++ ;;
++esac
++
+ if test "$gpl" != "yes"; then
+ if test "$pp" != "no" -o "$shared_pp" != "no"; then
+ echo "The Postprocessing code is under GPL and --enable-gpl is not specified"
+@@ -662,7 +693,6 @@
+ bindir="$prefix"
+ fi
+
+-cc="${cross_prefix}${cc}"
+ ar="${cross_prefix}${ar}"
+ ranlib="${cross_prefix}${ranlib}"
+ strip="${cross_prefix}${strip}"
+@@ -753,21 +783,6 @@
+ fi
+
+ if test "$zlib" = "yes"; then
+-# check for zlib - mmu_man
+-cat > $TMPC << EOF
+-#include <zlib.h>
+-int main ( void ) {
+-if (zlibVersion() != ZLIB_VERSION)
+- puts("zlib version differs !!!");
+- return 1;
+-return 0;
+-}
+-EOF
+-$cc $CFLAGS -o $TMPE $TMPC -lz 2> /dev/null || zlib="no"
+-# $TMPE 2> /dev/null > /dev/null || zlib="no"
+-# XXX: more tests needed - runtime test
+-fi
+-if test "$zlib" = "yes"; then
+ extralibs="$extralibs -lz"
+ fi
+
+@@ -881,24 +896,8 @@
+ ##########################################
+ # SDL probe
+
+-cat > $TMPC << EOF
+-#include <SDL.h>
+-#undef main /* We don't want SDL to override our main() */
+-int main( void ) { return SDL_Init (SDL_INIT_VIDEO); }
+-EOF
+-
+ sdl_too_old=no
+-sdl=no
+-if sdl-config --version >/dev/null 2>&1 ; then
+-if $cc -o $TMPE `sdl-config --cflags` $TMPC `sdl-config --libs` > /dev/null 2>&1 ; then
+-_sdlversion=`sdl-config --version | sed 's/[^0-9]//g'`
+-if test "$_sdlversion" -lt 121 ; then
+-sdl_too_old=yes
+-else
+ sdl=yes
+-fi
+-fi
+-fi
+
+ ##########################################
+ # texi2html probe
diff --git a/recipes/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch
new file mode 100644
index 0000000000..e04fdab3e5
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/gcc4.patch
@@ -0,0 +1,146 @@
+--- ffmpeg-0.4.9-pre1/libavcodec/common.h.orig 2008-02-23 19:42:48.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/common.h 2008-02-23 19:08:09.000000000 -0500
+@@ -64,11 +64,11 @@
+
+ struct AVOption;
+ #ifdef HAVE_MMX
+-extern const struct AVOption avoptions_common[3 + 5];
++extern const struct AVOption *avoptions_common[2 + 5];
+ #else
+-extern const struct AVOption avoptions_common[3];
++extern const struct AVOption *avoptions_common[2];
+ #endif
+-extern const struct AVOption avoptions_workaround_bug[11];
++extern const struct AVOption *avoptions_workaround_bug[10];
+
+ #endif /* HAVE_AV_CONFIG_H */
+
+@@ -1292,10 +1292,6 @@ tend= rdtsc();\
+ #define time time_is_forbidden_due_to_security_issues
+ #define rand rand_is_forbidden_due_to_state_trashing
+ #define srand srand_is_forbidden_due_to_state_trashing
+-#if !(defined(LIBAVFORMAT_BUILD) || defined(_FRAMEHOOK_H))
+-#define printf please_use_av_log
+-#define fprintf please_use_av_log
+-#endif
+
+ #define CHECKED_ALLOCZ(p, size)\
+ {\
+--- ffmpeg-0.4.9-pre1/libavcodec/ac3tab.h.orig 2008-02-23 19:46:06.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/ac3tab.h 2008-02-23 19:08:09.000000000 -0500
+@@ -4,10 +4,10 @@
+ */
+
+ /* possible frequencies */
+-static const uint16_t ac3_freqs[3] = { 48000, 44100, 32000 };
++const uint16_t ac3_freqs[3] = { 48000, 44100, 32000 };
+
+ /* possible bitrates */
+-static const uint16_t ac3_bitratetab[19] = {
++const uint16_t ac3_bitratetab[19] = {
+ 32, 40, 48, 56, 64, 80, 96, 112, 128,
+ 160, 192, 224, 256, 320, 384, 448, 512, 576, 640
+ };
+@@ -15,7 +15,7 @@ static const uint16_t ac3_bitratetab[19]
+ /* AC3 MDCT window */
+
+ /* MDCT window */
+-static const int16_t ac3_window[256] = {
++const int16_t ac3_window[256] = {
+ 4, 7, 12, 16, 21, 28, 34, 42,
+ 51, 61, 72, 84, 97, 111, 127, 145,
+ 164, 184, 207, 231, 257, 285, 315, 347,
+@@ -144,27 +144,27 @@ static const uint8_t baptab[64]= {
+ 15, 15, 15, 15,
+ };
+
+-static const uint8_t sdecaytab[4]={
++const uint8_t sdecaytab[4]={
+ 0x0f, 0x11, 0x13, 0x15,
+ };
+
+-static const uint8_t fdecaytab[4]={
++const uint8_t fdecaytab[4]={
+ 0x3f, 0x53, 0x67, 0x7b,
+ };
+
+-static const uint16_t sgaintab[4]= {
++const uint16_t sgaintab[4]= {
+ 0x540, 0x4d8, 0x478, 0x410,
+ };
+
+-static const uint16_t dbkneetab[4]= {
++const uint16_t dbkneetab[4]= {
+ 0x000, 0x700, 0x900, 0xb00,
+ };
+
+-static const uint16_t floortab[8]= {
++const uint16_t floortab[8]= {
+ 0x2f0, 0x2b0, 0x270, 0x230, 0x1f0, 0x170, 0x0f0, 0xf800,
+ };
+
+-static const uint16_t fgaintab[8]= {
++const uint16_t fgaintab[8]= {
+ 0x080, 0x100, 0x180, 0x200, 0x280, 0x300, 0x380, 0x400,
+ };
+
+--- ffmpeg-0.4.9-pre1/libavcodec/dsputil.h.orig 2008-02-23 19:47:34.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/dsputil.h 2008-02-23 19:08:09.000000000 -0500
+@@ -558,15 +558,15 @@ static int name16(void /*MpegEncContext*
+ /* XXX: add ISOC specific test to avoid specific BSD testing. */
+ /* better than nothing implementation. */
+ /* btw, rintf() is existing on fbsd too -- alex */
+-static inline long int lrintf(float x)
+-{
+-#ifdef CONFIG_WIN32
+- /* XXX: incorrect, but make it compile */
+- return (int)(x);
+-#else
+- return (int)(rint(x));
+-#endif
+-}
++//static inline long int lrintf(float x)
++//{
++//#ifdef CONFIG_WIN32
++// /* XXX: incorrect, but make it compile */
++// return (int)(x);
++//#else
++// return (int)(rint(x));
++//#endif
++//}
+ #else
+ #ifndef _ISOC9X_SOURCE
+ #define _ISOC9X_SOURCE
+--- ffmpeg-0.4.9-pre1/libavcodec/opts.c.orig 2008-02-23 19:49:11.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/opts.c 2008-02-23 19:08:09.000000000 -0500
+@@ -12,7 +12,7 @@
+
+ #include "avcodec.h"
+
+-const AVOption avoptions_common[] = {
++const AVOption *avoptions_common[] = {
+ AVOPTION_CODEC_FLAG("bit_exact", "use only bit-exact stuff", flags, CODEC_FLAG_BITEXACT, 0),
+ AVOPTION_CODEC_FLAG("mm_force", "force mm flags", dsp_mask, FF_MM_FORCE, 0),
+ #ifdef HAVE_MMX
+@@ -22,10 +22,10 @@ const AVOption avoptions_common[] = {
+ AVOPTION_CODEC_FLAG("mm_sse", "mask SSE feature", dsp_mask, FF_MM_SSE, 0),
+ AVOPTION_CODEC_FLAG("mm_sse2", "mask SSE2 feature", dsp_mask, FF_MM_SSE2, 0),
+ #endif
+- AVOPTION_END()
++// AVOPTION_END()
+ };
+
+-const AVOption avoptions_workaround_bug[] = {
++const AVOption *avoptions_workaround_bug[] = {
+ AVOPTION_CODEC_FLAG("bug_autodetect", "workaround bug autodetection", workaround_bugs, FF_BUG_AUTODETECT, 1),
+ AVOPTION_CODEC_FLAG("bug_old_msmpeg4", "workaround old msmpeg4 bug", workaround_bugs, FF_BUG_OLD_MSMPEG4, 0),
+ AVOPTION_CODEC_FLAG("bug_xvid_ilace", "workaround XviD interlace bug", workaround_bugs, FF_BUG_XVID_ILACE, 0),
+@@ -36,7 +36,7 @@ const AVOption avoptions_workaround_bug[
+ AVOPTION_CODEC_FLAG("bug_std_qpel", "workaround std qpel bug", workaround_bugs, FF_BUG_STD_QPEL, 0),
+ AVOPTION_CODEC_FLAG("bug_qpel_chroma2", "workaround qpel chroma2 bug", workaround_bugs, FF_BUG_QPEL_CHROMA2, 0),
+ AVOPTION_CODEC_FLAG("bug_direct_blocksize", "workaround direct blocksize bug", workaround_bugs, FF_BUG_DIRECT_BLOCKSIZE, 0),
+- AVOPTION_END()
++// AVOPTION_END()
+ };
+
+ /* avoid compatibility problems by redefining it */
diff --git a/recipes/ffmpeg/ffmpeg-0.4.9-pre1/install-must-not-strip.patch b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/install-must-not-strip.patch
new file mode 100644
index 0000000000..6fbeb3eb88
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/install-must-not-strip.patch
@@ -0,0 +1,47 @@
+Index: ffmpeg-0.4.9-pre1/libavcodec/Makefile
+===================================================================
+--- ffmpeg-0.4.9-pre1.orig/libavcodec/Makefile 2008-08-30 11:13:14.000000000 +0200
++++ ffmpeg-0.4.9-pre1/libavcodec/Makefile 2008-08-30 11:13:34.000000000 +0200
+@@ -267,10 +267,10 @@
+ ifeq ($(BUILD_SHARED),yes)
+ install: all install-headers
+ ifeq ($(CONFIG_WIN32),yes)
+- install -s -m 755 $(SLIB) "$(prefix)"
++ install -m 755 $(SLIB) "$(prefix)"
+ else
+ install -d $(prefix)/lib
+- install -s -m 755 $(SLIB) $(prefix)/lib/libavcodec.so.0.4.9
++ install -m 755 $(SLIB) $(prefix)/lib/libavcodec.so.0.4.9
+ ln -sf libavcodec.so.0.4.9 $(prefix)/lib/libavcodec.so.0
+ ln -sf libavcodec.so.0.4.9 $(prefix)/lib/libavcodec.so
+ ldconfig || true
+Index: ffmpeg-0.4.9-pre1/libavcodec/libpostproc/Makefile
+===================================================================
+--- ffmpeg-0.4.9-pre1.orig/libavcodec/libpostproc/Makefile 2008-08-30 11:13:14.000000000 +0200
++++ ffmpeg-0.4.9-pre1/libavcodec/libpostproc/Makefile 2008-08-30 11:13:40.000000000 +0200
+@@ -50,7 +50,7 @@
+ install: all
+ ifeq ($(SHARED_PP),yes)
+ install -d $(prefix)/lib
+- install -s -m 755 $(SPPLIB) $(prefix)/lib/$(SPPLIB).$(SPPVERSION)
++ install -m 755 $(SPPLIB) $(prefix)/lib/$(SPPLIB).$(SPPVERSION)
+ ln -sf $(SPPLIB).$(SPPVERSION) $(prefix)/lib/$(SPPLIB)
+ ldconfig || true
+ mkdir -p $(prefix)/include/postproc
+Index: ffmpeg-0.4.9-pre1/libavformat/Makefile
+===================================================================
+--- ffmpeg-0.4.9-pre1.orig/libavformat/Makefile 2008-08-30 11:13:14.000000000 +0200
++++ ffmpeg-0.4.9-pre1/libavformat/Makefile 2008-08-30 11:13:46.000000000 +0200
+@@ -103,10 +103,10 @@
+ ifeq ($(BUILD_SHARED),yes)
+ install: all install-headers
+ ifeq ($(CONFIG_WIN32),yes)
+- install -s -m 755 $(SLIB) "$(prefix)"
++ install -m 755 $(SLIB) "$(prefix)"
+ else
+ install -d $(prefix)/lib
+- install -s -m 755 $(SLIB) $(prefix)/lib/libavformat.so.0.4.9
++ install -m 755 $(SLIB) $(prefix)/lib/libavformat.so.0.4.9
+ ln -sf libavformat.so.0.4.9 $(prefix)/lib/libavformat.so.0
+ ln -sf libavformat.so.0.4.9 $(prefix)/lib/libavformat.so
+ ldconfig || true
diff --git a/recipes/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch
new file mode 100644
index 0000000000..80bf3937e4
--- /dev/null
+++ b/recipes/ffmpeg/ffmpeg-0.4.9-pre1/soname.patch
@@ -0,0 +1,84 @@
+--- ffmpeg-0.4.9-pre1/libavcodec/Makefile.orig 2008-02-23 19:34:18.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavcodec/Makefile 2008-02-23 19:24:55.000000000 -0500
+@@ -7,7 +7,7 @@ include ../config.mak
+ VPATH=$(SRC_PATH)/libavcodec
+
+ # NOTE: -I.. is needed to include config.h
+-CFLAGS=$(OPTFLAGS) -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
++CFLAGS=$(OPTFLAGS) -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -fPIC -DPIC
+
+ OBJS= common.o utils.o mem.o allcodecs.o \
+ mpegvideo.o jrevdct.o jfdctfst.o jfdctint.o\
+@@ -89,9 +89,10 @@ endif
+
+ ifeq ($(CONFIG_PP),yes)
+ ifeq ($(SHARED_PP),yes)
+-EXTRALIBS += -lpostproc
++LIBS += -lpostproc
+ else
+ # LIBS += libpostproc/libpostproc.a ... should be fixed
++LIBS += libpostproc/libpostproc.a
+ OBJS += libpostproc/postprocess.o
+ endif
+ endif
+@@ -197,7 +198,7 @@ ifeq ($(CONFIG_WIN32),yes)
+ $(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS)
+ -lib /machine:i386 /def:$(@:.dll=.def)
+ else
+- $(CC) $(SHFLAGS) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS) $(LDFLAGS)
++ $(CC) $(SHFLAGS) -o $@ $(OBJS) $(EXTRALIBS) $(AMREXTRALIBS) $(LDFLAGS) -Wl,-soname -Wl,libavcodec.so.0
+ endif
+
+ dsputil.o: dsputil.c dsputil.h
+@@ -269,8 +270,9 @@ ifeq ($(CONFIG_WIN32),yes)
+ install -s -m 755 $(SLIB) "$(prefix)"
+ else
+ install -d $(prefix)/lib
+- install -s -m 755 $(SLIB) $(prefix)/lib/libavcodec-$(VERSION).so
+- ln -sf libavcodec-$(VERSION).so $(prefix)/lib/libavcodec.so
++ install -s -m 755 $(SLIB) $(prefix)/lib/libavcodec.so.0.4.9
++ ln -sf libavcodec.so.0.4.9 $(prefix)/lib/libavcodec.so.0
++ ln -sf libavcodec.so.0.4.9 $(prefix)/lib/libavcodec.so
+ ldconfig || true
+ endif
+ else
+--- ffmpeg-0.4.9-pre1/libavformat/Makefile.orig 2008-02-23 19:37:40.000000000 -0500
++++ ffmpeg-0.4.9-pre1/libavformat/Makefile 2008-02-23 19:06:56.000000000 -0500
+@@ -6,7 +6,7 @@ include ../config.mak
+
+ VPATH=$(SRC_PATH)/libavformat
+
+-CFLAGS=$(OPTFLAGS) -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
++CFLAGS=$(OPTFLAGS) -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -fPIC -DPIC
+
+ OBJS= utils.o cutils.o os_support.o allformats.o
+ PPOBJS=
+@@ -54,6 +54,7 @@ endif
+ ifeq ($(CONFIG_AUDIO_BEOS),yes)
+ PPOBJS+= beosaudio.o
+ EXTRALIBS+=-lbe -lmedia
++else
+ # this should be the default !
+ EXTRALIBS+=-lavcodec -L../libavcodec
+ endif
+@@ -93,7 +94,7 @@ ifeq ($(CONFIG_WIN32),yes)
+ $(CC) $(SHFLAGS) -Wl,--output-def,$(@:.dll=.def) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) $(VPATH)/../libavcodec/avcodec.dll
+ -lib /machine:i386 /def:$(@:.dll=.def)
+ else
+- $(CC) $(SHFLAGS) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS)
++ $(CC) $(SHFLAGS) -o $@ $(OBJS) $(PPOBJS) $(EXTRALIBS) -Wl,-soname -Wl,libavformat.so.0
+ endif
+
+ depend: $(SRCS)
+@@ -105,8 +106,9 @@ ifeq ($(CONFIG_WIN32),yes)
+ install -s -m 755 $(SLIB) "$(prefix)"
+ else
+ install -d $(prefix)/lib
+- install -s -m 755 $(SLIB) $(prefix)/lib/libavformat-$(VERSION).so
+- ln -sf libavformat-$(VERSION).so $(prefix)/lib/libavformat.so
++ install -s -m 755 $(SLIB) $(prefix)/lib/libavformat.so.0.4.9
++ ln -sf libavformat.so.0.4.9 $(prefix)/lib/libavformat.so.0
++ ln -sf libavformat.so.0.4.9 $(prefix)/lib/libavformat.so
+ ldconfig || true
+ endif
+ else