aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fsi-client/fsi-client_20040803.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fsi-client/fsi-client_20040803.bb')
-rw-r--r--recipes/fsi-client/fsi-client_20040803.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/fsi-client/fsi-client_20040803.bb b/recipes/fsi-client/fsi-client_20040803.bb
new file mode 100644
index 0000000000..84c185abf9
--- /dev/null
+++ b/recipes/fsi-client/fsi-client_20040803.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "ipaq h5400 fingerprint identification driver and client library for Linux"
+SRC_URI = "http://heim.ifi.uio.no/~jorgenam/h5400/fsi-client-${PV}.tar.gz"
+SECTION = "libs"
+LICENSE = "GPL"
+
+CFLAGS += "-std=c99"
+
+S = "${WORKDIR}/client"
+
+FILES_${PN} += "${libdir}/libfsiclient.so"
+
+do_compile() {
+ oe_runmake all examples
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install libfsiclient.so ${D}${libdir}
+ install fsidumpraw fsidumppgm ${D}${bindir}
+}
+