aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc13
1 files changed, 12 insertions, 1 deletions
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index 7c856532ed..fbff553d29 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -1,8 +1,19 @@
require gdb-cross.inc
LICENSE = "GPLv3"
-INC_PR = "r6"
+INC_PR = "r7"
inherit sdk
DEPENDS = "ncurses-sdk zlib-sdk flex-native"
+EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
+
+do_configure_append () {
+ cd ${B}
+ oe_runmake configure-host
+ sed -e 's,-lncurses,${STAGING_LIBDIR_NATIVE}/libncurses.a ${STAGING_LIBDIR_NATIVE}/libtinfo.a ,g' -i ${B}/gdb/Makefile
+ sed -e 's,-lz, ${STAGING_LIBDIR_NATIVE}/libz.a ,g' -i ${B}/gdb/Makefile
+ sed -e 's,-lexpat, ${STAGING_LIBDIR_NATIVE}/libexpat.a ,g' -i ${B}/gdb/Makefile
+ sed -e 's,libexpat.so,libexpat.a ,g' -i ${B}/gdb/Makefile
+ sed -e 's,-lz, ${STAGING_LIBDIR_NATIVE}/libz.a ,g' -i ${B}/sim/arm/Makefile
+} \ No newline at end of file