aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hdparm/hdparm_6.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hdparm/hdparm_6.9.bb')
-rw-r--r--recipes/hdparm/hdparm_6.9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/hdparm/hdparm_6.9.bb b/recipes/hdparm/hdparm_6.9.bb
new file mode 100644
index 0000000000..337a7e1e8b
--- /dev/null
+++ b/recipes/hdparm/hdparm_6.9.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
+ file://bswap.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove hdparm hdparm.${PN}
+} \ No newline at end of file