aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/initrdscripts/initramfs-module-block_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/initrdscripts/initramfs-module-block_1.0.bb')
-rw-r--r--recipes/initrdscripts/initramfs-module-block_1.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/initrdscripts/initramfs-module-block_1.0.bb b/recipes/initrdscripts/initramfs-module-block_1.0.bb
new file mode 100644
index 0000000000..b4b2d43150
--- /dev/null
+++ b/recipes/initrdscripts/initramfs-module-block_1.0.bb
@@ -0,0 +1,12 @@
+SRC_URI = "file://85-blockboot.sh"
+PR = "r3"
+RDEPENDS = "initramfs-uniboot"
+DESCRIPTION = "An initramfs module for booting off normal block devices."
+
+do_install() {
+ install -d ${D}/initrd.d
+ install -m 0755 ${WORKDIR}/85-blockboot.sh ${D}/initrd.d/
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += " /initrd.d/* "