aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kismet/kismet-2010-07-R1
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/kismet/kismet-2010-07-R1')
-rw-r--r--recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch11
-rw-r--r--recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff20
-rw-r--r--recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff10
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch b/recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch
new file mode 100644
index 0000000000..1973768479
--- /dev/null
+++ b/recipes/kismet/kismet-2010-07-R1/hardcoded-usr.patch
@@ -0,0 +1,11 @@
+--- kismet-2010-07-R1/configure.in
++++ kismet-2010-07-R1/configure.in
+@@ -407,7 +407,7 @@
+ AC_SUBST(wantclient)
+
+ # Add additional cflags since some distros bury panel.h
+-CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
++CPPFLAGS="$CPPFLAGS `ncurses-config --cflags`"
+
+ termcontrol="none";
+
diff --git a/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff
new file mode 100644
index 0000000000..958fede18b
--- /dev/null
+++ b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-infinite-loop.diff
@@ -0,0 +1,20 @@
+--- extra/kismet2cwgd.cc
++++ extra/kismet2cwgd.cc
+@@ -874,7 +874,7 @@
+
+ // Break up the path to the gpsxml file and form a path based on that
+ unsigned int lastslash = 0;
+- for (unsigned int x = origxmlfile.find('/'); x != string::npos;
++ for (string::size_type x = origxmlfile.find('/'); x != string::npos;
+ lastslash = x, x = origxmlfile.find('/', lastslash+1)) {
+ // We don't actually need to do anything...
+ }
+@@ -882,7 +882,7 @@
+ comp = origxmlfile.substr(0, lastslash);
+
+ lastslash = 0;
+- for (unsigned int x = orignetfile.find('/'); x != string::npos;
++ for (string::size_type x = orignetfile.find('/'); x != string::npos;
+ lastslash = x, x = orignetfile.find('/', lastslash+1)) {
+ // We don't actually need to do anything...
+ }
diff --git a/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff
new file mode 100644
index 0000000000..e068f8dac5
--- /dev/null
+++ b/recipes/kismet/kismet-2010-07-R1/kismet-2008-05-R1-nonvoid.diff
@@ -0,0 +1,10 @@
+--- pcapsource.cc
++++ pcapsource.cc
+@@ -2914,6 +2914,7 @@
+ return -1;
+
+ }
++ return -1;
+ }
+ #endif
+