aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdes/libdes_4.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libdes/libdes_4.01.bb')
-rw-r--r--recipes/libdes/libdes_4.01.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/libdes/libdes_4.01.bb b/recipes/libdes/libdes_4.01.bb
new file mode 100644
index 0000000000..4e81ff9fb6
--- /dev/null
+++ b/recipes/libdes/libdes_4.01.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A DES encryption library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "libdes"
+SRC_URI = "http://www.agentpp.com/libdes-l-${PV}.tar.gz \
+ file://cross-compile.patch;patch=1"
+S = "${WORKDIR}/libdes"
+
+do_compile() {
+ oe_runmake libdes.a
+}
+
+do_stage() {
+ oe_libinstall -a libdes ${STAGING_LIBDIR}
+ install -m 0644 ${S}/des.h ${STAGING_INCDIR}/
+}