aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libopie
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libopie')
-rw-r--r--recipes/libopie/libopie2.inc69
-rw-r--r--recipes/libopie/libopie2/c7x0_w100_disable.patch20
-rw-r--r--recipes/libopie/libopie2/gcc-syntax-fix.patch13
-rw-r--r--recipes/libopie/libopie2/h4000_and_default_rot.patch25
-rw-r--r--recipes/libopie/libopie2/ipaq_rotate_fix.patch23
-rw-r--r--recipes/libopie/libopie2/libopie2-tosa.patch14
-rw-r--r--recipes/libopie/libopie2/rotate_fix.patch87
-rw-r--r--recipes/libopie/libopie2/spitz_rotate_fix.patch23
-rw-r--r--recipes/libopie/libopie2_1.2.4.bb13
-rw-r--r--recipes/libopie/libopie2_1.2.5.bb11
-rw-r--r--recipes/libopie/libopie2_cvs.bb10
11 files changed, 43 insertions, 265 deletions
diff --git a/recipes/libopie/libopie2.inc b/recipes/libopie/libopie2.inc
index a5a5cef0bd..e91ac7b6e5 100644
--- a/recipes/libopie/libopie2.inc
+++ b/recipes/libopie/libopie2.inc
@@ -17,18 +17,19 @@ PARALLEL_MAKE = ""
EXTRA_QMAKEVARS_POST += 'DEFINES+=OPIE_NEW_MALLOC \
DEFINES+="OPIE_SOUND_FRAGMENT_SHIFT=16" \
DEFINES+=OPIE_NO_ERASE_RECT_HACKFIX \
- LIBS+=-L${S} LIBS+="-Wl,-rpath-link,${S}"'
+ LIBS+=-L${S} LIBS+="-Wl,-rpath-link,${S}" \
+ INCLUDEPATH+=${S}/include'
ENABLE_SQL_PIM_BACKEND = "y"
# NOTE: Machines with too little amount of flash may want to disable SQL backend support
-# (known not to fit in 16MB). Also, XML backend is still used by default, as SQL doesn't
-# support sync yet.
+# (known not to fit in 16MB).
#ENABLE_SQL_PIM_BACKEND_smallmachine = "n"
EXTRA_QMAKEVARS_PRE += 'ENABLE_SQL_PIM_BACKEND=${ENABLE_SQL_PIM_BACKEND}'
MODULES = "opiecore opiedb opiemm opienet opiepim opiesecurity opieui opiebluez"
LIBS = "core2 db2 mm2 net2 pim2 security2 ui2 bluez2"
-PRIVATE = "opimcontactsortvector.h opimoccurrence_p.h opimsortvector.h opimtodosortvector.h vobject_p.h opimeventsortvector.h"
+PRIVATE = "opimcontactsortvector.h opimoccurrence_p.h opimsortvector.h \
+ opimtodosortvector.h vobject_p.h opimeventsortvector.h opimmemosortvector.h"
# uclibc doesn't have backtrace()
python __anonymous () {
@@ -38,44 +39,56 @@ python __anonymous () {
}
do_compile() {
- install -d ${STAGING_INCDIR}/opie2
- install -d ${STAGING_INCDIR}/opie2/private
- for module in ${MODULES}
- do
- cd $module
- for i in `find . -name "*.h"`
- do
- install -m 0644 $i ${STAGING_INCDIR}/opie2/`basename $i`
- done
- cd ..
- done
+ install -d ${S}/include/opie2
+ for module in ${MODULES}
+ do
+ cd $module
+ for i in `find . -name "*.h"`
+ do
+ filenm=`echo $i | sed 's!^\./!!'`
+ ln -sf ../../$module/$filenm ${S}/include/opie2/
+ done
+ cd ..
+ done
+ install -d ${S}/include/opie2/private
for header in ${PRIVATE}
do
- install -m 0644 opiepim/private/$header ${STAGING_INCDIR}/opie2/private/
+ ln -sf ../../../opiepim/private/$header ${S}/include/opie2/private
done
oe_runmake MOC=${STAGING_BINDIR_NATIVE}/moc UIC=${STAGING_BINDIR_NATIVE}/uic DESTDIR=${S}
}
-do_stage() {
- for f in ${LIBS}
- do
- oe_libinstall -so libopie$f ${STAGING_LIBDIR}/
- done
- install -m 0644 ${WORKDIR}/include.pro ${OPIEDIR}/include.pro
- # special case for uic-created header files
- install -m 0644 opiepim/ui/opimrecurrencebase.h ${STAGING_INCDIR}/opie2/
- install -m 0644 opieui/otimepickerbase.h ${STAGING_INCDIR}/opie2/
- install -m 0644 opiepim/core/opimtemplatebase.h ${STAGING_INCDIR}/opie2/
-}
-
do_install() {
install -d ${D}${libdir}
for f in ${LIBS}
do
oe_libinstall -so libopie$f ${D}${libdir}
done
+
+ install -m 0644 ${WORKDIR}/include.pro ${OPIEDIR}/include.pro
+
+ install -d ${D}${includedir}/opie2/
+ for module in ${MODULES}
+ do
+ cd $module
+ for i in `find . -name "*.h"`
+ do
+ if [[ $i != ./private/* ]] ; then
+ install -m 0644 $i ${D}${includedir}/opie2/`basename $i`
+ fi
+ done
+ cd ..
+ done
+ # Remove some headers we don't want packaged
+ rm ${D}${includedir}/opie2/stable_pch.h
+ rm ${D}${includedir}/opie2/ofileselector_p.h
+ rm ${D}${includedir}/opie2/okeyconfigwidget_p.h
+ rm ${D}${includedir}/opie2/okeyconfigmanager_p.h
+ rm ${D}${includedir}/opie2/ima_rw.h
+ rm ${D}${includedir}/opie2/udp_ports.h
+ rm ${D}${includedir}/opie2/odevice_*.h
}
PACKAGES_prepend = " libopiecore2 libopiedb2 libopiesecurity2 libopiemm2 libopienet2 libopiepim2 libopieui2 libopiebluez2 "
diff --git a/recipes/libopie/libopie2/c7x0_w100_disable.patch b/recipes/libopie/libopie2/c7x0_w100_disable.patch
deleted file mode 100644
index 959c56c443..0000000000
--- a/recipes/libopie/libopie2/c7x0_w100_disable.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- libopie2/opiecore/device/odevice_zaurus.cpp 10 Aug 2008 09:07:32 -0000 1.55
-+++ libopie2/opiecore/device/odevice_zaurus.cpp 20 Sep 2008 23:56:20 -0000
-@@ -313,14 +313,14 @@
- }
-
- // set default qte driver
-- switch( d->m_model )
-+/* switch( d->m_model )
- {
- case Model_Zaurus_SLC7x0:
- d->m_qteDriver = "W100";
- break;
-- default:
-+ default:*/
- d->m_qteDriver = "Transformed";
-- }
-+// }
-
- m_leds[0] = Led_Off;
-
diff --git a/recipes/libopie/libopie2/gcc-syntax-fix.patch b/recipes/libopie/libopie2/gcc-syntax-fix.patch
deleted file mode 100644
index 12b64d7d37..0000000000
--- a/recipes/libopie/libopie2/gcc-syntax-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/opiedb/osqldriver.h b/opiedb/osqldriver.h
-index 492b8dd..29fbfd6 100644
---- a/opiedb/osqldriver.h
-+++ b/opiedb/osqldriver.h
-@@ -77,7 +77,7 @@ public:
- /**
- * Get a list of tables
- */
-- virtual OSQLTable::ValueList tables() const = 0l;
-+ virtual OSQLTable::ValueList tables() const = 0;
- virtual bool sync();
-
-
diff --git a/recipes/libopie/libopie2/h4000_and_default_rot.patch b/recipes/libopie/libopie2/h4000_and_default_rot.patch
deleted file mode 100644
index c10160d0b8..0000000000
--- a/recipes/libopie/libopie2/h4000_and_default_rot.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- libopie2/opiecore/device/odevice_ipaq.cpp.org 2007-09-09 02:44:41.000000000 +0300
-+++ libopie2/opiecore/device/odevice_ipaq.cpp 2007-11-09 12:01:56.000000000 +0200
-@@ -178,6 +178,10 @@
- d->m_model = Model_iPAQ_HX4700;
- else if ( d->m_modelstr == "H4000" )
- d->m_model = Model_iPAQ_H4xxx;
-+ else if ( d->m_modelstr == "H4100" )
-+ d->m_model = Model_iPAQ_H4xxx;
-+ else if ( d->m_modelstr == "H4300" )
-+ d->m_model = Model_iPAQ_H4xxx;
-
- else
- d->m_model = Model_Unknown;
-@@ -198,8 +202,10 @@
- case Model_iPAQ_H36xx:
- case Model_iPAQ_H37xx:
- case Model_iPAQ_H39xx:
-- default:
- d->m_rotation = Rot270;
-+ break;
-+ default:
-+ d->m_rotation = Rot0;
- break;
-
- }
diff --git a/recipes/libopie/libopie2/ipaq_rotate_fix.patch b/recipes/libopie/libopie2/ipaq_rotate_fix.patch
deleted file mode 100644
index 9dfdb4fbf7..0000000000
--- a/recipes/libopie/libopie2/ipaq_rotate_fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- libopie2/opiecore/device/odevice_ipaq.cpp 2008-05-26 16:33:01.000000000 +0100
-+++ libopie2/opiecore/device/odevice_ipaq.cpp 2008-05-26 16:33:40.000000000 +0100
-@@ -331,16 +331,10 @@
- case Key_Down : {
- int quarters;
- switch (d->m_rotation) {
-- case Rot0: quarters = 3/*270deg*/; break;
-- case Rot90: quarters = 2/*270deg*/; break;
-- case Rot180: quarters = 1/*270deg*/; break;
-- case Rot270: quarters = 0/*270deg*/; break;
-- }
-- if( d->m_model == Model_iPAQ_H22xx ) {
-- // FIXME: there's something screwed with the keycodes being sent on h2200. I have
-- // added a temporary workaround for this here, but the bug should be fixed properly
-- // later in the right place. - Paul Eggleton 25/07/2007
-- quarters = 0;
-+ case Rot0: quarters = 0/*0deg*/; break;
-+ case Rot90: quarters = 1/*90deg*/; break;
-+ case Rot180: quarters = 2/*180deg*/; break;
-+ case Rot270: quarters = 3/*270deg*/; break;
- }
- newkeycode = Key_Left + ( keycode - Key_Left + quarters ) % 4;
- break;
diff --git a/recipes/libopie/libopie2/libopie2-tosa.patch b/recipes/libopie/libopie2/libopie2-tosa.patch
deleted file mode 100644
index 5d83111d21..0000000000
--- a/recipes/libopie/libopie2/libopie2-tosa.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: libopie2/opiecore/device/odevice_zaurus.cpp
-===================================================================
---- libopie2.orig/opiecore/device/odevice_zaurus.cpp 2008-12-01 06:38:14.670256416 +0300
-+++ libopie2/opiecore/device/odevice_zaurus.cpp 2008-12-01 07:47:16.045256590 +0300
-@@ -286,6 +286,9 @@ void Zaurus::init(const QString& cpu_inf
- case Model_Zaurus_SL5500:
- m_backlightdev = "/sys/class/backlight/locomo-bl/";
- break;
-+ case Model_Zaurus_SL6000:
-+ m_backlightdev = "/sys/class/backlight/tosa-bl/";
-+ break;
- default:
- m_backlightdev = "/sys/class/backlight/corgi-bl/";
- }
diff --git a/recipes/libopie/libopie2/rotate_fix.patch b/recipes/libopie/libopie2/rotate_fix.patch
deleted file mode 100644
index c6a59846a0..0000000000
--- a/recipes/libopie/libopie2/rotate_fix.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- libopie2/opiecore/device/odevice_ipaq.cpp 24 May 2009 20:09:49 -0000 1.40
-+++ libopie2/opiecore/device/odevice_ipaq.cpp 27 May 2009 21:16:24 -0000
-@@ -35,6 +35,7 @@
- #include <qfile.h>
- #include <qtextstream.h>
- #include <qwindowsystem_qws.h>
-+#include <qgfx_qws.h>
-
- /* OPIE */
- #include <qpe/config.h>
-@@ -335,11 +336,11 @@
- int quarters;
- switch (d->m_rotation) {
- case Rot0: quarters = 0/*0deg*/; break;
-- case Rot90: quarters = 1/*90deg*/; break;
-+ case Rot90: quarters = 3/*90deg*/; break;
- case Rot180: quarters = 2/*180deg*/; break;
-- case Rot270: quarters = 3/*270deg*/; break;
-+ case Rot270: quarters = 1/*270deg*/; break;
- }
-- newkeycode = Key_Left + ( keycode - Key_Left + quarters ) % 4;
-+ newkeycode = Key_Left + ( keycode - Key_Left + quarters + qt_screen->transformOrientation() ) % 4;
- break;
- }
-
---- libopie2/opiecore/device/odevice_zaurus.cpp 24 May 2009 20:09:49 -0000 1.57
-+++ libopie2/opiecore/device/odevice_zaurus.cpp 27 May 2009 21:16:24 -0000
-@@ -807,16 +807,8 @@
- case Key_Up :
- case Key_Down :
- {
-- if (d->m_model == Model_Zaurus_SLC3000) {
-- // This ensures that the cursor keys work correctly and that the
-- // side wheel works as expected when the screen is flipped over
-- if (rotation() == Rot270)
-- newkeycode = Key_Left + ( keycode - Key_Left + 1 ) % 4;
-- }
-- else {
-- if (rotation()==Rot90)
-- newkeycode = Key_Left + ( keycode - Key_Left + 3 ) % 4;
-- }
-+ if (rotation()==Rot90)
-+ newkeycode = Key_Left + ( keycode - Key_Left + 3 ) % 4;
- break;
-
- }
---- libopie2/opiecore/device/odevice_palm.cpp 2009-05-27 22:28:37.000000000 +0100
-+++ libopie2/opiecore/device/odevice_palm.cpp 2009-05-27 22:28:09.000000000 +0100
-@@ -295,25 +295,21 @@
- {
- int newkeycode = keycode;
-
-- if (qt_screen->transformOrientation() != Rot0){
--
-- switch ( keycode ) {
-- case Key_Left :
-- case Key_Right:
-- case Key_Up :
-- case Key_Down :
-- newkeycode = Key_Left + ( keycode - Key_Left + 4 ) % 4;
-- default:
-- break;
-- }
-+ switch ( keycode ) {
-+ case Key_Left :
-+ case Key_Right:
-+ case Key_Up :
-+ case Key_Down :
-+ newkeycode = Key_Left + ( keycode - Key_Left + qt_screen->transformOrientation() ) % 4;
-+ default:
-+ break;
-+ }
-
-- if (newkeycode!=keycode) {
-- if ( newkeycode != Key_unknown ) {
-- QWSServer::sendKeyEvent ( -1, newkeycode, modifiers, isPress, autoRepeat );
-- }
-- return true;
-+ if (newkeycode!=keycode) {
-+ if ( newkeycode != Key_unknown ) {
-+ QWSServer::sendKeyEvent ( -1, newkeycode, modifiers, isPress, autoRepeat );
- }
--
-+ return true;
- }
-
- return false;
diff --git a/recipes/libopie/libopie2/spitz_rotate_fix.patch b/recipes/libopie/libopie2/spitz_rotate_fix.patch
deleted file mode 100644
index 428ec0d4cf..0000000000
--- a/recipes/libopie/libopie2/spitz_rotate_fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- libopie2/opiecore/device/odevice_zaurus.cpp 30 Jul 2007 19:10:52 -0000 1.53
-+++ libopie2/opiecore/device/odevice_zaurus.cpp 8 Aug 2008 23:15:15 -0000
-@@ -760,9 +760,18 @@
- case Key_Up :
- case Key_Down :
- {
-- if (rotation()==Rot90) {
-- newkeycode = Key_Left + ( keycode - Key_Left + 3 ) % 4;
-+ if (d->m_model == Model_Zaurus_SLC3000) {
-+ // This ensures that the cursor keys work correctly and that the
-+ // side wheel works as expected when the screen is flipped over
-+ if (rotation() == Rot270)
-+ newkeycode = Key_Left + ( keycode - Key_Left + 1 ) % 4;
- }
-+ else {
-+ if (rotation()==Rot90)
-+ newkeycode = Key_Left + ( keycode - Key_Left + 3 ) % 4;
-+ }
-+ break;
-+
- }
- break;
-
diff --git a/recipes/libopie/libopie2_1.2.4.bb b/recipes/libopie/libopie2_1.2.4.bb
deleted file mode 100644
index 4e0baf6910..0000000000
--- a/recipes/libopie/libopie2_1.2.4.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require ${PN}.inc
-
-PR = "r4"
-
-SRC_URI = "http://sources.openembedded.org/opie-1.2.4-split_libopie2.tar.bz2;name=split_libopie2 \
- file://include.pro \
- file://libopie2-tosa.patch \
- file://c7x0_w100_disable.patch \
- file://rotate_fix.patch"
-SRC_URI[split_libopie2.md5sum] = "4fc656b48eff8c535426423161732e75"
-SRC_URI[split_libopie2.sha256sum] = "d1ef19d697b0b7b2ff5c17de7a6d401074748198dac5af9584f6f66be52dcfc7"
-
-SRC_URI_append_poodle = " file://poodle-2.6-hotkeys.patch"
diff --git a/recipes/libopie/libopie2_1.2.5.bb b/recipes/libopie/libopie2_1.2.5.bb
index 4525ad741e..79f71dc990 100644
--- a/recipes/libopie/libopie2_1.2.5.bb
+++ b/recipes/libopie/libopie2_1.2.5.bb
@@ -1,8 +1,6 @@
require ${PN}.inc
-PR = "r1"
-
-DEFAULT_PREFERENCE = "-1"
+PR = "r3"
SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_libopie2.tar.bz2;name=split_libopie2 \
file://gcc45_opiemm_include.patch \
@@ -10,13 +8,6 @@ SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_libopie2.tar.bz2;nam
SRC_URI[split_libopie2.md5sum] = "7258c4154c91b28a24030e029782da6f"
SRC_URI[split_libopie2.sha256sum] = "5e1d831c9e5acbba15a3ec78aba5eff5f5dbf5e27cf469f6de693176fc7cd621"
-PRIVATE += " opimmemosortvector.h"
-
# FIXME remove this!
SRC_URI_append_poodle = " file://poodle-2.6-hotkeys.patch"
-do_stage_append() {
- # special case for uic-created header files
- install -m 0644 opiepim/ui/opimalarmdlgbase.h ${STAGING_INCDIR}/opie2/
-}
-
diff --git a/recipes/libopie/libopie2_cvs.bb b/recipes/libopie/libopie2_cvs.bb
index 671f86e3cb..8ffefe07fd 100644
--- a/recipes/libopie/libopie2_cvs.bb
+++ b/recipes/libopie/libopie2_cvs.bb
@@ -1,20 +1,12 @@
require ${PN}.inc
PV = "${OPIE_GIT_PV}"
-PR = "r13"
+PR = "r14"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${OPIE_GIT};protocol=git;subpath=libopie2 \
file://include.pro"
-PRIVATE += " opimmemosortvector.h"
-
# FIXME remove this!
SRC_URI_append_poodle = " file://poodle-2.6-hotkeys.patch"
-
-do_stage_append() {
- # special case for uic-created header files
- install -m 0644 opiepim/ui/opimalarmdlgbase.h ${STAGING_INCDIR}/opie2/
-}
-