aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsndfile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsndfile')
-rw-r--r--recipes/libsndfile/libsndfile1_1.0.20.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/libsndfile/libsndfile1_1.0.20.bb b/recipes/libsndfile/libsndfile1_1.0.20.bb
new file mode 100644
index 0000000000..2562271af2
--- /dev/null
+++ b/recipes/libsndfile/libsndfile1_1.0.20.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "An audio format Conversion library"
+HOMEPAGE = "http://www.mega-nerd.com/libsndfile"
+AUTHOR = "Erik de Castro Lopo"
+SECTION = "libs/multimedia"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.mega-nerd.com/libsndfile/libsndfile-${PV}.tar.gz \
+ "
+
+S = "${WORKDIR}/libsndfile-${PV}"
+
+inherit autotools_stage lib_package pkgconfig
+
+do_configure_prepend_arm() {
+ export ac_cv_sys_largefile_source=1
+ export ac_cv_sys_file_offset_bits=64
+ ac_cv_sizeof_off_t=8
+}
+
+PACKAGES =+ "${PN}-octave"
+FILES_${PN}-octave += "/usr/share/octave/site/m"