aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool/libtool_2.2.6a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libtool/libtool_2.2.6a.bb')
-rw-r--r--recipes/libtool/libtool_2.2.6a.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/libtool/libtool_2.2.6a.bb b/recipes/libtool/libtool_2.2.6a.bb
index 3eb2080f2f..e2996c7198 100644
--- a/recipes/libtool/libtool_2.2.6a.bb
+++ b/recipes/libtool/libtool_2.2.6a.bb
@@ -19,10 +19,12 @@ EXTRA_AUTORECONF = "--exclude=libtoolize"
do_configure_prepend () {
# Skip this for native build:
if test -n "$CONFIG_SITE" ; then
- export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
- export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
- export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
- export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ if test -z "$LIBTOOL_BB_DO_NOT_SET_PATHS" ; then
+ export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
+ export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
+ export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
+ export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
+ fi
fi
}