aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxslt/libxslt_1.1.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libxslt/libxslt_1.1.22.bb')
-rw-r--r--recipes/libxslt/libxslt_1.1.22.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/libxslt/libxslt_1.1.22.bb b/recipes/libxslt/libxslt_1.1.22.bb
new file mode 100644
index 0000000000..86fe70dff2
--- /dev/null
+++ b/recipes/libxslt/libxslt_1.1.22.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch;patch=1"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"