aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-z_2.6.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-z_2.6.20.bb')
-rw-r--r--recipes/linux/linux-z_2.6.20.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-z_2.6.20.bb b/recipes/linux/linux-z_2.6.20.bb
new file mode 100644
index 0000000000..8c5c940155
--- /dev/null
+++ b/recipes/linux/linux-z_2.6.20.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "2.6 Linux Development Kernel for the DNARD/Shark, SIMpad."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+inherit kernel
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://www.openembedded.org/~zecke/git/linux/linux-2.6/.git;protocol=http \
+ file://defconfig"
+
+
+RPROVIDES_kernel-image += "hostap-modules"
+
+COMPATIBLE_HOST = "(arm).*-linux"
+COMPATIBLE_MACHINE = '(shark)'
+
+
+
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}