aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pyrex-native_0.9.8.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pyrex-native_0.9.8.5.bb')
-rw-r--r--recipes/python/python-pyrex-native_0.9.8.5.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes/python/python-pyrex-native_0.9.8.5.bb b/recipes/python/python-pyrex-native_0.9.8.5.bb
new file mode 100644
index 0000000000..4405212040
--- /dev/null
+++ b/recipes/python/python-pyrex-native_0.9.8.5.bb
@@ -0,0 +1,10 @@
+require python-pyrex_${PV}.bb
+inherit native
+DEPENDS = "python-native"
+RDEPENDS = ""
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}