aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb')
-rw-r--r--recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb b/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb
new file mode 100644
index 0000000000..675d07c910
--- /dev/null
+++ b/recipes/samsung-soc-utils/s3c2410-boot-usb-native_svn.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Boots a S3C2410 device with a user supplied kernel zImage"
+DEPENDS = "libusb-native"
+SECTION = "devel"
+AUTHOR = "Harald Welte <laforge@openmoko.org>"
+LICENSE = "GPL"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=s3c2410_boot_usb;proto=https"
+S = "${WORKDIR}/s3c2410_boot_usb"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -lusb -o s3c2410-boot-usb boot_usb.c
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 s3c2410-boot-usb ${DEPLOY_DIR_TOOLS}/s3c2410-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile