aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/swfdec/swfdec-mozilla_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/swfdec/swfdec-mozilla_0.8.2.bb')
-rw-r--r--recipes/swfdec/swfdec-mozilla_0.8.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/swfdec/swfdec-mozilla_0.8.2.bb b/recipes/swfdec/swfdec-mozilla_0.8.2.bb
new file mode 100644
index 0000000000..bfb5c208d1
--- /dev/null
+++ b/recipes/swfdec/swfdec-mozilla_0.8.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Swfdec plugin for browsers using NPAPI. Swfdec is a decoder/renderer for Macromedia Flash animations."
+LICENSE = "LGPL"
+
+DEPENDS = "swfdec glib-2.0"
+RDEPENDS = "gst-ffmpeg"
+
+SRC_URI = "http://swfdec.freedesktop.org/download/swfdec-mozilla/0.8/${P}.tar.gz \
+"
+
+inherit autotools pkgconfig gtk-icon-cache
+
+EXTRA_OECONF = "--disable-static"
+
+do_install_append() {
+ rm ${D}${libdir}/mozilla/plugins/*.la
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/mozilla/plugins/*.so"
+FILES_${PN}-dbg += "${libdir}/mozilla/plugins/.debug"
+