aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xmonobut/xmonobut_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xmonobut/xmonobut_0.4.bb')
-rw-r--r--recipes/xmonobut/xmonobut_0.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/xmonobut/xmonobut_0.4.bb b/recipes/xmonobut/xmonobut_0.4.bb
new file mode 100644
index 0000000000..97ebcbd84c
--- /dev/null
+++ b/recipes/xmonobut/xmonobut_0.4.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+PR = "r1"
+DESCRIPTION = "utility to allow middle and right clicking with a stylus"
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxext libxpm"
+SRC_URI = "http://www.handhelds.org/~mallum/downloadables/xmonobut/xmonobut-${PV}.tar.gz \
+ file://xmonobut.desktop"
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -m 0755 xmonobut ${D}${bindir}/xmonobut
+ install -m 0644 xmonobut.xpm ${D}${datadir}/pixmaps/xmonobut.xpm
+ install -m 0644 ${WORKDIR}/xmonobut.desktop ${D}${datadir}/applications/xmonobut.desktop
+}