aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xorg-lib')
-rw-r--r--recipes/xorg-lib/libx11_1.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/xorg-lib/libx11_1.2.bb b/recipes/xorg-lib/libx11_1.2.bb
index a3d000f030..e9665bcc2f 100644
--- a/recipes/xorg-lib/libx11_1.2.bb
+++ b/recipes/xorg-lib/libx11_1.2.bb
@@ -13,6 +13,11 @@ SRC_URI += "file://x11_disable_makekeys.patch;patch=1 \
EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+# Dolt gets used on x86 and ppc and hardcodes 'libtool'
+do_configure_append() {
+ cp ${TARGET_PREFIX}libtool libtool || true
+}
+
do_compile() {
(
unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS