aboutsummaryrefslogtreecommitdiffstats
path: root/usermanual/reference
diff options
context:
space:
mode:
Diffstat (limited to 'usermanual/reference')
-rw-r--r--usermanual/reference/class_autotools.xml10
-rw-r--r--usermanual/reference/class_binconfig.xml4
-rw-r--r--usermanual/reference/class_distutils.xml38
-rw-r--r--usermanual/reference/class_image_ipkg.xml12
-rw-r--r--usermanual/reference/class_update-alternatives.xml2
-rw-r--r--usermanual/reference/class_update-rc.d.xml7
-rw-r--r--usermanual/reference/image_types.xml10
7 files changed, 42 insertions, 41 deletions
diff --git a/usermanual/reference/class_autotools.xml b/usermanual/reference/class_autotools.xml
index a14b6d6ee8..2614209045 100644
--- a/usermanual/reference/class_autotools.xml
+++ b/usermanual/reference/class_autotools.xml
@@ -100,7 +100,7 @@ do_install_append () {
application breaks the build of another. It is a very good idea to
empty the site file of all other values if you are having build
problems to ensure that none of the existing values are causing
- problems. </para>
+ problems.</para>
</listitem>
<listitem>
@@ -121,9 +121,9 @@ do_install_append () {
endianess option to the configure script:<screen>do_configure() {
# endianness fun.. inspired by openssl.inc
. ${CONFIG_SITE}
- if test "x$ac_cv_c_bigendian" = "xyes"; then
+ if [ "x$ac_cv_c_bigendian" = "xyes" -o "x$ac_cv_c_littleendian" = "xno" ]; then
ENDIANESS=" --with-endianness=big"
- elif test "x$ac_cv_c_littleendian" = "xyes"; then
+ elif [ "x$ac_cv_c_littleendian" = "xyes" -o "x$ac_cv_c_bigendian" = "xno" ]; then
ENDIANESS=" --with-endianness=little"
else
oefatal do_configure cannot determine endianess
@@ -131,8 +131,8 @@ do_install_append () {
oe_runconf $ENDIANESS
}</screen>It is also possible to disable the use of the cached values from the
site file by clearing the definition of <command>CONFIG_SITE</command>
- prior to running the configure script. Doing this disables the use of the
- site file entirely. This however should be used as a last resort. The
+ prior to running the configure script. Doing this will disable the use of
+ the site file entirely. This however should be used as a last resort. The
following example from the db recipe shows an example of this:<screen># Cancel the site stuff - it's set for db3 and destroys the
# configure.
CONFIG_SITE = ""
diff --git a/usermanual/reference/class_binconfig.xml b/usermanual/reference/class_binconfig.xml
index bf6290039d..618f9fefd1 100644
--- a/usermanual/reference/class_binconfig.xml
+++ b/usermanual/reference/class_binconfig.xml
@@ -4,8 +4,8 @@
<para>The binconfig class is for packages that install
<command>&lt;pkg&gt;-config</command> scripts that provide information about
- the build settings for the package. It's usually provided by libraries which
- and is used by other packages to determine various compiler options.</para>
+ the build settings for the package. It is usually provided by libraries
+ and then used by other packages to determine various compiler options.</para>
<para>Since the script is used at build time it is required to be copied
into the staging area. All the actions performed by the class are appended
diff --git a/usermanual/reference/class_distutils.xml b/usermanual/reference/class_distutils.xml
index f2a2ec8957..ddc9c721ab 100644
--- a/usermanual/reference/class_distutils.xml
+++ b/usermanual/reference/class_distutils.xml
@@ -3,36 +3,38 @@
<title>distutils class</title>
<para>Distutils is a standard python system for building and installing
- modules. This class is used to automate the building of python modules that
- use the distutils system.</para>
+ modules. The <emphasis>distutils</emphasis> class is used to automate the
+ building of python modules that use the distutils system.</para>
<para>Any python package that requires the standard python commands to build
- and install: <screen>python setup.py build
-python setup.py install</screen>is using distutils and can use this class.
- </para>
+ and install is using the distutils system and should be able to use this
+ class:<screen>python setup.py build
+python setup.py install</screen></para>
- <para>The distutils class will perform the build and install actions on the
- setup.py package as required for building distutils packages, including
- setting all the required parameters for cross compiling. It'll also do the
- following:</para>
+ <para>The <emphasis>distutils</emphasis> class will perform the build and
+ install actions on the <command>setup.py</command> provided by the package,
+ as required for building distutils packages, including setting all the
+ required parameters for cross compiling. It willl also perform the following
+ actions:</para>
<orderedlist>
<listitem>
- <para>Adds python-native to DEPENDS to ensure that python is built and
- installed on the build host. This also ensure that the version of python
- that is used during package creation matches the version of python that
- will be installed on the target.</para>
+ <para>Adds python-native to <command>DEPENDS</command> to ensure that
+ python is built and installed on the build host. This also ensure that
+ the version of python that is used during package creation matches the
+ version of python that will be installed on the target.</para>
</listitem>
<listitem>
- <para>Adds python-core to RDEPENDS to ensure that the python-core is
- installed when this module is installed. Note that you need to manually
- add any other python module dependencies to RDEPENDS.</para>
+ <para>Adds python-core to <command>RDEPENDS</command> to ensure that the
+ python-core is installed when this module is installed. Note that you
+ need to manually add any other python module dependencies to
+ <command>RDEPENDS</command>.</para>
</listitem>
</orderedlist>
- <para>The following example from the moin recipe shows how simple this can
- make a python package:<screen>DESCRIPTION = "A full fledged WikiWiki system written in Python"
+ <para>The following example from the <emphasis>moin</emphasis> recipe shows
+ how simple this can make a python package:<screen>DESCRIPTION = "A full fledged WikiWiki system written in Python"
LICENSE = "GPL"
SECTION = "base"
PRIORITY = "optional"
diff --git a/usermanual/reference/class_image_ipkg.xml b/usermanual/reference/class_image_ipkg.xml
index c81a76da2f..814068c711 100644
--- a/usermanual/reference/class_image_ipkg.xml
+++ b/usermanual/reference/class_image_ipkg.xml
@@ -3,11 +3,11 @@
<title>image_ipkg class</title>
<para>The image_ipkg class is used to generate images containing a root
- filesystem, as generate by the <xref linkend="rootfs_ipkg_class" /> class,
+ filesystem, as generated by the <xref linkend="rootfs_ipkg_class" /> class,
for use on the target device. This could be a <emphasis>jffs2</emphasis>
- image to be written into flash on the target device for example. In addition
- it also configures the ipkg feeds (where to get updates from) in the root
- filesystem and is able to generate multiple different image types.</para>
+ image which is to be written into the flash on the target device for
+ example. In addition this class also configures the ipkg feeds (where to get
+ updates from) and is able to generate multiple different image types.</para>
<para>Summary of actions performed by the <emphasis>image_ipkg</emphasis>
class:</para>
@@ -243,8 +243,8 @@ IMAGE_DEVICE_TABLES = "files/device_table-minimal.txt files/device_table_add-sci
<listitem>
<para>This contains details fro creating the /dev/sm0 and
/dev/sm0p{0,1,2} devices nodes for the block driver and associated
- partitions that is used to managed the flash on the titan board.
- </para>
+ partitions that is used to managed the flash on the titan
+ board.</para>
</listitem>
</varlistentry>
</variablelist>
diff --git a/usermanual/reference/class_update-alternatives.xml b/usermanual/reference/class_update-alternatives.xml
index 4e8f64a32d..cd86e3e6ab 100644
--- a/usermanual/reference/class_update-alternatives.xml
+++ b/usermanual/reference/class_update-alternatives.xml
@@ -8,7 +8,7 @@
size perspective, but limited in functionality, while the bash version is
much larger but also provides far more features. The alternatives system is
designed to handle the situation where two commands are provided by two, or
- more, packages. It ensure that one of the alternatives is always the
+ more, packages. It ensures that one of the alternatives is always the
currently selected one and ensures that there are no problems with
installing and/or removing the various alternatives.</para>
diff --git a/usermanual/reference/class_update-rc.d.xml b/usermanual/reference/class_update-rc.d.xml
index c29501fe59..2da9b0bf86 100644
--- a/usermanual/reference/class_update-rc.d.xml
+++ b/usermanual/reference/class_update-rc.d.xml
@@ -86,10 +86,9 @@ root@titan:/etc#</screen>The start and stop sequence numbers need to ensure
<section>
<title>Multiple update-rc.d packages</title>
- <para>Define multiple init scripts within the one recipe is also supported
- but note that each init script must be in it's own package. You cannot
- have multiple init scripts in a single package. The following example is
- from the quagga recipe:<screen># Main init script starts all deamons
+ <para>Defining multiple init scripts within the one recipe is also
+ supported. Note that each init script must be in it's own package. The
+ following example is from the quagga recipe:<screen># Main init script starts all deamons
# Seperate init script for watchquagga
INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga"
INITSCRIPT_NAME_${PN} = "quagga"
diff --git a/usermanual/reference/image_types.xml b/usermanual/reference/image_types.xml
index 3ccfe9c4e0..4756c248d9 100644
--- a/usermanual/reference/image_types.xml
+++ b/usermanual/reference/image_types.xml
@@ -7,11 +7,11 @@
several variables which can be used to control the type of output images and
the settings for those images such as endianess or compression ratios. This
section details the available images and the variable that effect them. See
- the <emphasis>image_ipk</emphasis> class description in the reference
- section for details on how image generation is configured.</para>
+ the <xref linkend="image_ipkg_class" /> section for details on how image
+ generation is configured.</para>
<para>The final root file system will consist of all of the files located in
- <command>${IMAGE_ROOTFS}</command> which is usually
+ <command>${IMAGE_ROOTFS}</command>, which is usually
<command>tmp/rootfs</command> in your build area. One important difference
between the image and the root file system directory is that any files which
can only be created by privileged users, such as device nodes, will not
@@ -50,8 +50,8 @@
<listitem>
<para>Used to pass additional command line arguments to the
<command>IMAGE_CMD</command> without needing to redefine the entire
- image command. Often used to pass options such as endianess and
- compression rations. You need to look at the
+ image command. This is often used to pass options such as endianess
+ and compression rations. You need to look at the
<command>IMAGE_CMD</command> to determine which command these
options are being passed to.</para>
</listitem>