aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-24 14:28:05 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-24 20:24:26 -0700
commit98f3ebfa0393c6fa7a5e334e3221161765749270 (patch)
treee819d03a075c3001f4337ac0d9af51eaa11980c9 /meta-python/recipes-devtools
parent0eb4abcafd6aa0130533b3ea93125d636b8293bb (diff)
downloadmeta-openembedded-contrib-98f3ebfa0393c6fa7a5e334e3221161765749270.tar.gz
python3-parse: upgrade 1.19.0 -> 1.19.1
Switch to using git and a SRCREV to make sure we can keep the ptests. Changelog (https://github.com/r1chardj0n3s/parse/releases): - Add support for sign specifiers in number formats. by @anntzer in #134 - Fix handling of unused alignment by @tomerha in #132 - modern packaging by @wimglenn in #151 - universal wheel by @wimglenn in #155 Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.19.1.bb (renamed from meta-python/recipes-devtools/python/python3-parse_1.19.0.bb)17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb b/meta-python/recipes-devtools/python/python3-parse_1.19.1.bb
index 94c1b53c94..9dc7f79318 100644
--- a/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
+++ b/meta-python/recipes-devtools/python/python3-parse_1.19.1.bb
@@ -3,9 +3,18 @@ HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
-SRC_URI[sha256sum] = "9ff82852bcb65d139813e2a5197627a94966245c897796760a3a2a8eb66f020b"
+SRC_URI[sha256sum] = "cc3a47236ff05da377617ddefa867b7ba983819c664e1afe46249e5b469be464"
-inherit pypi setuptools3 ptest
+SRC_URI += " \
+ git://github.com/r1chardj0n3s/parse.git;branch=master;protocol=https \
+ file://run-ptest \
+"
+
+SRCREV ?= "72776522285d516032faa0f80c4ee6a8964075e8"
+
+S = "${WORKDIR}/git"
+
+inherit python_setuptools_build_meta ptest
RDEPENDS:${PN} += "\
python3-datetime \
@@ -13,10 +22,6 @@ RDEPENDS:${PN} += "\
python3-numbers \
"
-SRC_URI += " \
- file://run-ptest \
-"
-
RDEPENDS:${PN}-ptest += " \
python3-pytest \
"