aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/xorg-lib/libxext_1.2.0.bb12
-rw-r--r--recipes-graphics/xorg-lib/libxrender_0.9.6.bb13
-rw-r--r--recipes-graphics/xorg-lib/xorg-lib-common.inc17
3 files changed, 42 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-lib/libxext_1.2.0.bb b/recipes-graphics/xorg-lib/libxext_1.2.0.bb
new file mode 100644
index 0000000000..f4482e652e
--- /dev/null
+++ b/recipes-graphics/xorg-lib/libxext_1.2.0.bb
@@ -0,0 +1,12 @@
+require xorg-lib-common.inc
+DESCRIPTION = "X11 miscellaneous extension library"
+DEPENDS += "xproto virtual/libx11 xextproto libxau"
+PE = "1"
+PR = "${INC_PR}.0"
+
+SRC_URI[archive.md5sum] = "9bb236ff0193e9fc1c1fb504dd840331"
+SRC_URI[archive.sha256sum] = "4aed3e211e41c47908c293515580e731c26048f61a1212bf0888d1f456de6ff7"
+
+BBCLASSEXTEND = "native nativesdk"
+
+XORG_PN = "libXext"
diff --git a/recipes-graphics/xorg-lib/libxrender_0.9.6.bb b/recipes-graphics/xorg-lib/libxrender_0.9.6.bb
new file mode 100644
index 0000000000..0828af11f4
--- /dev/null
+++ b/recipes-graphics/xorg-lib/libxrender_0.9.6.bb
@@ -0,0 +1,13 @@
+require xorg-lib-common.inc
+DESCRIPTION = "X11 Rendering Extension client library"
+LICENSE = "BSD-X"
+DEPENDS += "virtual/libx11 renderproto xproto libxdmcp"
+PE = "1"
+PR = "${INC_PR}.0"
+
+SRC_URI[archive.md5sum] = "3b3b7d076c2384b6c600c0b5f4ba971f"
+SRC_URI[archive.sha256sum] = "7f58b1e263109e0a873eef8423aa14733a5499befbe645053aa622ed1f3ea668"
+
+BBCLASSEXTEND = "native nativesdk"
+
+XORG_PN = "libXrender"
diff --git a/recipes-graphics/xorg-lib/xorg-lib-common.inc b/recipes-graphics/xorg-lib/xorg-lib-common.inc
new file mode 100644
index 0000000000..6073621a8b
--- /dev/null
+++ b/recipes-graphics/xorg-lib/xorg-lib-common.inc
@@ -0,0 +1,17 @@
+HOMEPAGE = "http://www.x.org"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xorg"
+
+SECTION = "x11/libs"
+LICENSE = "MIT-X"
+DEPENDS = "util-macros"
+
+XORG_PN = "${BPN}"
+INC_PR = "r9"
+
+SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${XORG_PN}-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-malloc0returnsnull"