aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/epiphany/epiphany_2.30.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/epiphany/epiphany_2.30.6.bb b/meta-gnome/recipes-gnome/epiphany/epiphany_2.30.6.bb
new file mode 100644
index 0000000000..a507899627
--- /dev/null
+++ b/meta-gnome/recipes-gnome/epiphany/epiphany_2.30.6.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "GNOME default webbrowser"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "libsoup-2.4 webkit-gtk gtk+ gconf iso-codes startup-notification ca-certificates"
+
+inherit gnome
+
+EXTRA_OECONF += " --disable-nss --with-distributor-name=${DISTRO} --without-ca-file"
+
+do_configure_prepend() {
+ touch ${S}/gnome-doc-utils.make
+ sed -i -e s:help::g Makefile.am
+}
+
+FILES_${PN} += "${datadir}/icons ${datadir}/dbus-1"
+RDEPENDS_${PN} = "iso-codes"
+RRECOMMENDS_${PN} = "ca-certificates"
+