aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 09:05:53 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-27 07:57:30 -0700
commit0a815da7bdb178169e046c29b37ce56b87a3f10e (patch)
treee62467c7d5b9c35ee5514e286b2f6066d4cea6a8 /meta-oe
parent02b230b7f42a4009e082bac00b66c8d66691047a (diff)
downloadmeta-openembedded-0a815da7bdb178169e046c29b37ce56b87a3f10e.tar.gz
aer-inject: Fix build with latest musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch32
-rw-r--r--meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 0000000000..358ff524ef
--- /dev/null
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,32 @@
+From a2ccd98076c2ac81830234555edf362ee19a337d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 25 Mar 2024 09:00:41 -0700
+Subject: [PATCH] include libgen.h for basename
+
+basename prototype has been removed from string.h from latest musl [1]
+compilers e.g. clang-18 flags the absense of prototype as error. therefore
+include libgen.h for providing it.
+
+[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
+
+Upstream-Status: Submitted [Emailed patch to Author]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ aer-inject.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/aer-inject.c b/aer-inject.c
+index 74e7f72..eed1211 100644
+--- a/aer-inject.c
++++ b/aer-inject.c
+@@ -11,6 +11,7 @@
+ */
+
+ #include <stdio.h>
++#include <libgen.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <fcntl.h>
+--
+2.44.0
+
diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
index fbc6bdfbed..6a7699803c 100644
--- a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
@@ -11,6 +11,7 @@ LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;protocol=https;branch=master \
+ file://0001-include-libgen.h-for-basename.patch \
"
SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
@@ -26,4 +27,4 @@ do_install() {
oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr/' install
}
FILES:${PN} += "/usr/aer-inject"
-BBCLASSEXTEND = "native nativesdk" \ No newline at end of file
+BBCLASSEXTEND = "native nativesdk"