aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-19 11:10:10 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-22 08:38:08 -0700
commit502048818daa8bc755db6213b677c83636ba569b (patch)
tree924812a4e240d32a8f7dbbcac870583e98ac06c6 /meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb
parent1ac66c0dd74febf52e1a34041a9a0b06374abee5 (diff)
downloadmeta-openembedded-502048818daa8bc755db6213b677c83636ba569b.tar.gz
python3-prompt-toolkit: Upgrade 2.0.10 -> 3.0.5
Upgrade to release 3.0.5 and add HOMEPAGE. The new release brings: New features: - (almost) 100% type annotated. - Native asyncio instead of custom event loops. - Added shift-based text selection. - Added many more vt100 ANSI sequences and keys. - Improved control/shift key support in Windows. - No Mypy errors in prompt_toolkit anymore. - Added `set_exception_handler` optional argument to `PromptSession.prompt()`. Breaking changes: - Python 2 support has been dropped. Minimal Python version is now 3.6, although 3.7 is preferred (because of ContextVars). - Native asyncio, so some async code becomes slightly different. - The active `Application` became a contextvar. Which means that it should be propagated correctly to the code that requires it. However, random other threads or coroutines won't be able to know what the current application is. - The dialog shortcuts API changed. All dialog functions now return an `Application`. You still have to call either `run()` or `run_async` on the `Application` object. - The way inputhooks work is changed. - `patch_stdout` now requires an `Application` as input. - `ShiftControl` has been replaced with `ControlShift` and `s-c` with `c-s` in key bindings. Aliases for backwards-compatibility have been added. Fixes: - Bugfix in invalidate code. `PromptSession` was invalidating the UI continuously. - Add uvloop support. - Forwarded `set_exception_handler` in `Application.run` to the `run_async` call. - Bugfix in `NestedCompleter` when there is a leading space. - Bugfix in mouse handling on Windows. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb
new file mode 100644
index 0000000000..b4d20c2cd7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.5.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Library for building powerful interactive command lines in Python"
+HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
+
+SRC_URI[md5sum] = "96ba0be8d3145eb70e3da25654987670"
+SRC_URI[sha256sum] = "563d1a4140b63ff9dd587bda9557cffb2fe73650205ab6f4383092fb882e7dc8"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "prompt_toolkit"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-wcwidth \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"