aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bftpd/bftpd_2.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bftpd/bftpd_2.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bftpd/bftpd_2.3.bb')
-rw-r--r--recipes/bftpd/bftpd_2.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/bftpd/bftpd_2.3.bb b/recipes/bftpd/bftpd_2.3.bb
new file mode 100644
index 0000000000..242a613be5
--- /dev/null
+++ b/recipes/bftpd/bftpd_2.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Portable ftp daemon"
+HOMEPAGE = "http://bftpd.sourceforge.net/"
+SECTION = "console/network"
+PR = "r2"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ file://bftpd.conf \
+ "
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${mandir}/man8
+ install -d ${D}${sysconfdir}
+
+ install -m 0755 ${S}/bftpd ${D}${sbindir}/bftpd
+ install -m 0755 ${S}/bftpd.8 ${D}${mandir}/man8/bftpd.8
+ install -m 0644 ${WORKDIR}/bftpd.conf ${D}${sysconfdir}/bftpd.conf
+}