aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-bootsplash/gpe-bootsplash_svn.bb')
-rw-r--r--recipes/gpe-bootsplash/gpe-bootsplash_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb b/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
new file mode 100644
index 0000000000..56267ce48a
--- /dev/null
+++ b/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
@@ -0,0 +1,36 @@
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libsvg-cairo"
+PR = "r1"
+PV = "1.15+svn-${SRCDATE}"
+
+inherit autotools
+
+SRC_URI += "${GPE_SVN} \
+ file://splash-p.svg \
+ file://splash-l.svg \
+ file://init.patch;patch=1 \
+ file://svn-build.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
+ mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
+}
+
+FILES_${PN} += "${datadir}/gpe"
+
+pkg_postinst() {
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
+}
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
+}
+
+DEFAULT_PREFERENCE = "-1"