aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-bootsplash/gpe-bootsplash_svn.bb')
-rw-r--r--recipes/gpe-bootsplash/gpe-bootsplash_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb b/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
new file mode 100644
index 0000000000..56267ce48a
--- /dev/null
+++ b/recipes/gpe-bootsplash/gpe-bootsplash_svn.bb
@@ -0,0 +1,36 @@
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libsvg-cairo"
+PR = "r1"
+PV = "1.15+svn-${SRCDATE}"
+
+inherit autotools
+
+SRC_URI += "${GPE_SVN} \
+ file://splash-p.svg \
+ file://splash-l.svg \
+ file://init.patch;patch=1 \
+ file://svn-build.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
+ mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
+}
+
+FILES_${PN} += "${datadir}/gpe"
+
+pkg_postinst() {
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
+}
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
+}
+
+DEFAULT_PREFERENCE = "-1"