aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gputty/gputty_0.9.8.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gputty/gputty_0.9.8.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gputty/gputty_0.9.8.bb')
-rw-r--r--recipes/gputty/gputty_0.9.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/gputty/gputty_0.9.8.bb b/recipes/gputty/gputty_0.9.8.bb
new file mode 100644
index 0000000000..5e1ed06357
--- /dev/null
+++ b/recipes/gputty/gputty_0.9.8.bb
@@ -0,0 +1,27 @@
+# OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "GPuTTY is a PuTTY clone using the Gnome environment"
+HOMEPAGE = "http://www.defora.org/index.php?page=gputty"
+LICENSE = "GPL"
+SECTION = "network"
+PR = "r0"
+
+SRC_URI = "http://people.defora.org/~khorben/projects/gputty/gputty-${PV}.tar.gz \
+ file://gputty"
+
+do_compile() {
+ oe_runmake -C src
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ oe_runmake -C src BINDIR="${bindir}" DESTDIR="${D}" install
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/gputty ${D}${sysconfdir}/
+}
+
+# Save the configuration file in the package
+FILES_${PN} += " /etc/gputty"
+