aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf@emagii.com>2012-01-31 21:17:09 +0100
committerUlf Samuelsson <ulf@emagii.com>2012-02-09 21:09:05 +0100
commit53784a5e2622582ce5e2ffb91bbdb573503ed75e (patch)
tree60952b735bd09f4fafd37e91d68264f408fdf1fa /recipes/perl
parent19f9a4e7806b44ee4bb72e6391cd0cca69c525de (diff)
downloadopenembedded-53784a5e2622582ce5e2ffb91bbdb573503ed75e.tar.gz
intltool(-native) Fix dependencies.
intltool used to depend on libxml-parser-perl-native, which did not exist. The patch creates a new native recipe for libxml-parser-perl, and let intltool-native depend on this. intltool dependency is removed. Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libxml-parser-perl-native_2.36.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/perl/libxml-parser-perl-native_2.36.bb b/recipes/perl/libxml-parser-perl-native_2.36.bb
new file mode 100644
index 0000000000..e46cc59395
--- /dev/null
+++ b/recipes/perl/libxml-parser-perl-native_2.36.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "XML::Parser - A perl module for parsing XML documents"
+SECTION = "libs"
+LICENSE = "Artistic|GPLv1+"
+DEPENDS += "expat expat-native"
+PR= "r4"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
+
+S = "${WORKDIR}/XML-Parser-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+inherit native
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/lib -name 'libc-*.so')"
+ cpan_do_compile
+}
+# cpan_do_compile || echo expected failure
+
+do_compile_virtclass-native (){
+ cpan_do_compile
+}
+
+FILES_${PN} = "${PERLLIBDIRS}/auto/XML/Parser/Expat/* \
+ ${PERLLIBDIRS}/XML"
+
+BBCLASSEXTEND="native"
+
+SRC_URI[md5sum] = "1b868962b658bd87e1563ecd56498ded"
+SRC_URI[sha256sum] = "9fd529867402456bd826fe0e5588d35b3a2e27e586a2fd838d1352b71c2ed73f"